EIGRP产生默认路由有以下几种方法:

1、  redistribute static

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

interface Serial1/1

 ip address 12.1.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 Loopback0    //必须是接口

router eigrp 1

 redistribute static

 network 1.0.0.0

 network 12.0.0.0

 no auto-summary

 

2network 0.0.0.0

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

interface Serial1/1

 ip address 12.1.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 Loopback0

router eigrp 1

 network 1.0.0.0

 network 12.0.0.0

net 0.0.0.0

 no auto-summary

 

3、  default-network

interface Serial1/1

 ip address 12.1.1.1 255.255.255.0

interface Loopback3

 ip address 3.3.3.3 255.0.0.0

router eigrp 1

 network 3.0.0.0

 network 12.1.1.0 0.0.0.255

 network 192.168.1.0

 auto-summary

ip default-network 3.0.0.0   //必须是主类网络

R1#sh ip ro

C*   3.0.0.0/8 is directly connected, Loopback3

 

4、  ip summary-address eigrp 1 0.0.0.0 0.0.0.0

R1#sh run

interface Serial1/1

 ip address 12.1.1.1 255.255.255.0

 ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

router eigrp 1

 network 1.1.1.0 0.0.0.255

 network 12.1.1.0 0.0.0.255

 no auto-summary

R1上面没有产生默认路由,而在R2上:

R2(config)#do sh ip ro

D*   0.0.0.0/0 [90/2297856] via 12.1.1.1, 00:05:33, Serial1/0

R2上面产生了一条指向R1的默认路由。

=================我是分割线===================================

以上实验如有错误和疑问,欢迎指出,谢谢。