实验指南EIGRP
 
 
   Configure an IP network as depicted in Figure using EIGRP as the routing protocol and 2001 as the Autonomous System ID.
 
   Configure the Frame Relay network as a point−to−point network among all the routers. Do not create a multipoint network.
 
  Do not allow any other shops to see the subnet 172.16.3.0/24 on the barneys router.

  Inject a default route into the solar_bucks router pointing all traffic to the internet_router.

  The direct Frame link between solar_bucks and g_and_s router is very expensive. Configure EIGRP so that traffic from g_and_s will go first to barneys and then to solar_bucks. If the PVC between barneys and g_and_s drops, traffic will flow directly from g_and_s to solar_bucks.
 
配置实例
Internet_router

conf t
host Internet_router
int  f0/0
ip ad 172.16.50.1 255.255.255.0
no shut
router eigrp 2001
no au
net 172.16.50.1 0.0.0.0
end

Solar_bucks
conf t
host Solar_bucks
int f 0/0
ip ad 172.16.50.5 255.255.255.0
no shut
int s 2/0
encap f
no arp f
no shut
int s 2/0.1 point-to-point
ip ad 172.16.128.1 255.255.255.252
bandwidth 64
frame int 102
int s 2/0.2 point-to-point
ip ad 172.16.128.5 255.255.255.252
bandwidth 1544
frame int 103
exit
ip route 0.0.0.0 0.0.0.0 172.16.50.1
router eigrp 2001
no au
net 172.16.50.5 0.0.0.0
net 172.16.128.1 0.0.0.0
net 172.16.128.5 0.0.0.0
redistribute static metric 10000 100 255 1 1500
end

G_and_s
conf t
host G_and_s
int l 0
ip ad 172.16.60.1 255.255.255.0
int s 2/0
encap f
no arp f
no shut
int s 2/0.1 point-to-point
ip ad 172.16.128.2 255.255.255.252
bandwidth 64
frame interface-dlci 201
int s 2/0.2 point-to-point
ip ad 172.16.128.9 255.255.255.252
bandwidth 64
frame interface-dlci 203
router eigrp 2001
no au
net 172.16.60.1 0.0.0.0
net 172.16.128.2 0.0.0.0
net 172.16.128.9 0.0.0.0
end

Bameys
conf t
host Bameys
int l 0
ip ad 172.16.20.1 255.255.255.0
int l 1
ip ad 172.16.3.1 255.255.255.0
int s 2/0
encap f
no arp f
no shut
int s2/0.1 point-to-point
ip ad 172.16.128.6 255.255.255.252
bandwidth 1544
frame interface-dlci 301
int s 2/0.2 point-to-point
ip ad 172.16.128.10 255.255.255.252
bandwidth 64
frame interface-dlci 302
exit
access-list 1 deny 172.16.3.0 0.0.0.255
access-list 1 permit any
router eigrp 2001
no au
net 172.16.20.1 0.0.0.0
net 172.16.128.6 0.0.0.0
net 172.16.128.10 0.0.0.0
net 172.16.3.1 0.0.0.0
distribute-list 1 out s2/0.1
distribute-list 1 out s2/0.2
end
 
校验
Solar_bucks#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.50.1 to network 0.0.0.0
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
D       172.16.128.8/30 [90/41024000] via 172.16.128.2, 00:00:35, Serial2/0.1
                        [90/41024000] via 172.16.128.6, 00:00:35, Serial2/0.2
C       172.16.128.4/30 is directly connected, Serial2/0.2
C       172.16.128.0/30 is directly connected, Serial2/0.1
D       172.16.60.0/24 [90/40640000] via 172.16.128.2, 00:00:35, Serial2/0.1
C       172.16.50.0/24 is directly connected, FastEthernet0/0
D       172.16.20.0/24 [90/2297856] via 172.16.128.6, 00:00:34, Serial2/0.2
S*   0.0.0.0/0 [1/0] via 172.16.50.1

G_and_s#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.128.1 to network 0.0.0.0
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       172.16.128.8/30 is directly connected, Serial2/0.2
D       172.16.128.4/30 [90/41024000] via 172.16.128.1, 00:00:40, Serial2/0.1
                        [90/41024000] via 172.16.128.10, 00:00:40, Serial2/0.2
C       172.16.128.0/30 is directly connected, Serial2/0.1
C       172.16.60.0/24 is directly connected, Loopback0
D       172.16.50.0/24 [90/40514560] via 172.16.128.1, 00:00:40, Serial2/0.1
D       172.16.20.0/24 [90/40640000] via 172.16.128.10, 00:00:40, Serial2/0.2
D*EX 0.0.0.0/0 [170/40537600] via 172.16.128.1, 00:00:40, Serial2/0.1

Bameys#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.128.5 to network 0.0.0.0
     172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
C       172.16.128.8/30 is directly connected, Serial2/0.2
C       172.16.128.4/30 is directly connected, Serial2/0.1
D       172.16.128.0/30 [90/41024000] via 172.16.128.5, 00:00:47, Serial2/0.1
                        [90/41024000] via 172.16.128.9, 00:00:47, Serial2/0.2
D       172.16.60.0/24 [90/40640000] via 172.16.128.9, 00:00:47, Serial2/0.2
D       172.16.50.0/24 [90/2172416] via 172.16.128.5, 00:00:47, Serial2/0.1
C       172.16.20.0/24 is directly connected, Loopback0
C       172.16.3.0/24 is directly connected, Loopback1
D*EX 0.0.0.0/0 [170/2195456] via 172.16.128.5, 00:00:47, Serial2/0.1

Internet_router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.50.5 to network 0.0.0.0
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
D       172.16.128.8/30
           [90/41026560] via 172.16.50.5, 00:01:08, FastEthernet0/0
D       172.16.128.4/30
           [90/2172416] via 172.16.50.5, 00:22:50, FastEthernet0/0
D       172.16.128.0/30
           [90/40514560] via 172.16.50.5, 00:01:38, FastEthernet0/0
D       172.16.60.0/24
           [90/40642560] via 172.16.50.5, 00:00:58, FastEthernet0/0
C       172.16.50.0/24 is directly connected, FastEthernet0/0
D       172.16.20.0/24 [90/2300416] via 172.16.50.5, 00:00:52, FastEthernet0/0
D*EX 0.0.0.0/0 [170/284160] via 172.16.50.5, 00:06:09, FastEthernet0/0