A1058 A+B in Hogwarts (典型的进制转换问题)(20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题意:

本题题干同于B1037 在霍格沃茨找零钱,按照标准格式计算A+ B

思路:

本题进制转换可以采用两种思路:

  1. B1037 在霍格沃茨找零钱中,将所有数值全部划到最小的单位上去,相加之后再进行转换,输出即可——方法一
  2. 直接在三个单位上相加,要注意记录进位——方法二

注意:

  1. 本题实际上定义了一种数字N(x1, x2, x3),规定x3 为29进制,x2 为14进制, x1没有进制限制
  2. 方法一中:计算过程中和值最大值是2*(2*107*17*29+16*29+28)=1.972e+010,此值超出了int的范围,因此必须把所有的数据类型定义为long long

方法一:

#include <cstdio>
int main(){
  long long a1, b1, c1;
  long long a2, b2, c2;
  scanf("%lld.%lld.%lld %lld.%lld.%lld", &a1, &b1, &c1, &a2, &b2, &c2);
  long long price = a1 * 17 * 29 + b1 * 29 + c1;
  long long money = a2 * 17 * 29 + b2 * 29 + c2;
  long long change = money + price;

  printf("%lld.%lld.%lld\n", change / (17 * 29), change % (17 * 29) / 29, change % 29);
  return 0;
}

方法二:

#include <cstdio>
int main(){
  int a[3], b[3], c[3];
  scanf("%d.%d.%d %d.%d.%d", &a[0], &a[1], &a[2], &b[0], &b[1], &b[2]);
  int carry = 0; //进位
  c[2] = (a[2] + b[2]) % 29;
  carry = (a[2] + b[2]) / 29;
  c[1] = (a[1] + b[1] + carry) % 17;    //计算时把进位加进去
  carry = (a[1] + b[1] + carry) / 17;
  c[0] = a[0] + b[0] + carry;
  printf("%d.%d.%d", c[0], c[1], c[2]);
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值