A1035 Password (20 分)(修改密码)(字符串处理)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题意:

 给定N个用户的姓名(Name)和密码,现需要吧把密码中的‘1’ 给为 ‘@’, ‘0’ 改为 ‘%’, ‘l’ 改为 ‘L’, 'O' 改为 'o', 若没有修改的密码,按照单复数输出There is(are) 1(N) account(s) and no account is modified.其中N (≤1000), 字符数不超过10个。

思路:

本题的难点在于,输入的信息很多,需要记录的信息也很多。非常巧妙的在结构体中定义ischange,便于判断。并且用cnt记录修改的数目,非常方便

注意:

  1. 建立结构体存储姓名和密码,同时将该用户是否修改ischange存于结构体中。
  2. 函数 crypt 用于实现:判断输入的密码是否需要修改,进行修改,置ischange的值,同时增加计数器cnt的值。
  3. 当cnt==0时,即没有要修改的数时,注意单复数输出。
#include <cstdio>
#include <cstring>
struct node{
  char name[20], password[20];
  bool ischange;
}T[1005];

void crypt(node &t, int &cnt){
  int len = strlen(t.password);
  for(int i = 0; i < len; i++){
    if(t.password[i] == '1'){
      t.password[i] = '@';
      t.ischange = true;
    }
    else if(t.password[i] == '0'){
      t.password[i] = '%';
      t.ischange = true;
    }
    else if(t.password[i] == 'l'){
      t.password[i] = 'L';
      t.ischange = true;
    }
    else if(t.password[i] == 'O'){
      t.password[i] = 'o';
      t.ischange = true;
    }
  }
  if(t.ischange)
    cnt++;
}

int main(){
  int n, cnt = 0;
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    scanf("%s %s", T[i].name, T[i].password);
    T[i].ischange = false;  
  }
  for(int i = 0; i < n; i++)
    crypt(T[i], cnt);
  if(cnt == 0){
    if(n == 1)
      printf("There is 1 account and no account is modified");
    else
      printf("There are %d accounts and no account is modified", n);
  }
  else{
    printf("%d\n", cnt);
    for(int i = 0; i < n; i++){
      if(T[i].ischange)
        printf("%s %s\n", T[i].name, T[i].password);
    }
  }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值