A1078 Hashing (25 分)(给定序列哈希存储并处理冲突)(素数+冲突处理)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意:

给出散列表长TSize和欲插入的元素,将这些元素按读入的顺序插入散列表中,其中散列函数为H(key)=key%TSize,解决冲突采用只往正向增加的二次探查法。另外,如果题目给出的TSize不是素数,那么需要将TSize重新赋值为第一个比TSize大的素数,再进行元素插入。

样例解释:

TSize = 4,取第一个比4大的素数 TSize = 5,接着插入4个元素:

key = 10,10 % 5 = 0,插入0号位

key = 6, 6 % 5 = 1,插入1号位

key = 4,4 % 5 = 4, 插入4号位

key = 15,15 % 5 = 0,冲突;15 + 1 = 16, 16 % 5 = 1, 冲突;15 + 4 = 19, 19 % 5 = 4,冲突;15 + 9 = 24,24 % 5 = 4,冲突;15 + 16 = 31, 31 % 5 = 1,.... 可以证明找不到一个冲突的点。

思路:

本题的难点在于,对于二次探测的处理。

首先确定TSize,开bool型数组 HashTable,记录是否存储元素。本题中二次平方探测法要注意,冲突处理公式为 M = (a + step * step) % TSize; (此处要注意模 TSize)

注意:

  1. 注意输出时,第一个元素与其他元素分开处理,最后一个输出之后不能有空格
  2. 已证明,如果从 0 ~ TSize - 1进行枚举找不到位置,那么对于大于等于TSize的位置,也不可能存在,输出 "-"即可
#include <cstdio>
#include <cmath>
#include <vector>
using namespace std;
const int N = 11111;
bool isPrime(int n){
  if(n <= 1)
    return false;
  int sqr = (int)sqrt(1.0 * n);
  for(int i = 2; i <= sqr; i++){
    if(n % i == 0)
      return false;
  }
  return true;
}
bool hashTable[N] = {0};

int main(){
  int n, TSize, a;
  scanf("%d%d", &TSize, &n);
  while(isPrime(TSize) == false){
    TSize++;
  }
  for(int i = 0; i < n; i++){
    scanf("%d", &a);
    int M = a % TSize;
    if(hashTable[M] == false){
      hashTable[M] = true;
      if(i == 0)
        printf("%d", M);
      else
        printf(" %d", M);
    }
    else{
      int step;
      for(step = 1; step < TSize; step++){
        M = (a + step * step) % TSize;
        if(hashTable[M] == false){
          hashTable[M] = true;
          if(i == 0)
            printf("%d", M);
          else
            printf(" %d", M);
          break;
        }
      }
      if(step >= TSize){
        if(i > 0)
          printf(" ");
        printf("-");
      }
    }
  }
  return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值