The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
Now it's your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a -
will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
题意:
二叉树有 N 个结点(结点编号为 0 ~ N -1),给出每个节点的左右孩子节点编号,把该二叉树反转,输出反转后二叉树的层次遍历和中序遍历序列
思路:
题目给出的是节点编号的关系,使用二叉树的静态写法比较方便
层次遍历的写法要注意!
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 110;
struct node{
int lchild, rchild;
}Node[maxn];
bool notRoot[maxn] = {false};
int n, num = 0;
void print(int id){
printf("%d", id);
num++;
if(num < n)
printf(" ");
else
printf("\n");
}
void inorder(int root){
if(root == -1){
return;
}
inorder(Node[root].lchild);
print(root);
inorder(Node[root].rchild);
}
//层次遍历
void BFS(int root){
queue<int> q;
q.push(root);
while(!q.empty()){
int now = q.front();
q.pop();
print(now);
if(Node[now].lchild != -1)
q.push(Node[now].lchild);
if(Node[now].rchild != -1)
q.push(Node[now].rchild);
}
}
//后序遍历,用于反转字符串
void postOrder(int root){
if(root == -1)
return;
postOrder(Node[root].lchild);
postOrder(Node[root].rchild);
swap(Node[root].lchild, Node[root].rchild);
}
//将输入从字符转换为-1或者结点编号
int strToNum(char c){
if(c == '-')
return -1;
else{
notRoot[c - '0'] = true;
return c - '0';
}
}
int findRoot(){
for(int i = 0; i < n; i++){
if(notRoot[i] == false)
return i;
}
}
int main(){
char lchild, rchild;
scanf("%d", &n);
for(int i = 0; i < n; i++){
scanf("%*c%c %c", &lchild, &rchild);
Node[i].lchild = strToNum(lchild);
Node[i].rchild = strToNum(rchild);
}
int root = findRoot();
postOrder(root);
BFS(root);
num = 0;
inorder(root);
return 0;
}