1144 The Missing Number (20 分)

 

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

 

解题思路:这道题有个坑:数据范围在0~100000以内,但是注意题目这里出的有错误:For each case, the first line gives a positive integer N (≤10​^5​​). 题目明说给定的数据个数在1e5内,但是数据大小没有说在1e5以内,导致第一次提交出现段错误,我还以为是数组开的太小所致,还打算用二维数组做(并不能,没有别的办法了,数组并不能开到10位)

注:integer最大数据为一个十位数2147483647

 

测试点结果耗时内存
0答案正确3 ms592 KB
1答案正确2 ms356 KB
2答案正确2 ms396 KB
3答案正确2 ms384 KB
4答案正确80 ms384 KB
5答案正确71 ms808 KB
6段错误3 ms

352 KB

 

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

const int N = 1e5+5;
int a[N];

int main()
{
    int n,x;
    cin >> n;
    for(int i = 0; i < n; i++){
        cin >> x;
        if(x>0&&x<N) a[x] = 1;
    }
    for(int i = 1; i < N; i++){
        if(!a[i]){
            printf("%d",i);
            break;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值