1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

做此题的时候,最后一个测试点老是段错误,仔细查看下数据范围int,如果开一个int范围大小的数组判断,显然不可能,那么就猜下测试数据的范围。我将101010的数据都去除了,也就是说测试数据在101010前一定会出现一个最小数没有出现。当然,此时可能想如果出现大于101010的时候怎么办,还有猜数据太不靠谱了,这时可以另想别的办法,我们可以用set或者map集合,不用我们自己去开数组大小了。

#include<iostream>
using namespace std;
int main(){
	int n;
	cin >> n;
	int a[101010];
	for(int i = 1;i <= n;i++){
		int t;
		cin >> t;
		if(t > 0 && t < 101010){
			a[t] = 1;
		}
	}
	int top = 0;
	while(++top){
		if(a[top] == 0){
			cout << top << endl;
			break;
		}
	}
	return 0;
}
#include<iostream>
#include<set>
using namespace std;
int main(){
	int n;
	cin >> n;
	set<int> s;
	for(int i = 1;i <= n;i++){
		int t;
		cin >> t;
		if(t > 0){
			s.insert(t);
		}
	}
	int top = 1;
	int flag = 0;
	for(auto it = s.begin();it != s.end();it++,top++){
		//cout << *it << " " << top << endl;
		if(*it != top){
			cout << top << endl;
			flag = 1;
			break;
		}
	}
	if(flag==0){
		cout << top << endl;
	}
	return 0;
}

 

#include<iostream>
#include<map>
using namespace std;
int main(){
	int n;
	cin >> n;
	map<int,int> m;
	for(int i = 1;i <= n;i++){
		int t;
		cin >> t;
		if(t > 0){
			m[t] = 1;
		}
	}
	int top = 0;
	while(++top){
		if(m[top] == 0){
			cout << top << endl;
			break;
		}
	}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值