1042 Shuffling Machine (20 分)

1042 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

解题思路

  1. 注意如果只用一个vector进行插入删除操作来模拟此题的话,会出错,原因在于:每更新某一位置i的数据后,其他数据的位置也会相应发生改变,因此再更新该数据之后(i+1及之后)的数据时,此时这些位置的数据已经不是原来的数据了,而题目要求是将原数据一次性更新,更新k次

note

  1. vector没有你想的那么简单,vector的使用很有学问:
  2. 当时用元素直接赋值时v[i] = x必须要指定vector的大小,两个vector之间赋值时,两个vector的大小都必须指定
  3. vector指定大小后不能使用push_back()赋值
  4. 将一个vector赋值给另一个vector可用:(以下两种方法等价)
v1.assign(v2.begin(), v2.end());
//或
v1 = v2;
  1. clear()函数会将vector的元素清空,size置为0,清空之后vector就变成了指定大小的vector,不能再直接赋值,如:
vector<int> v(3);
printf("%d\n",v.size());//3
v.clear();
printf("%d",v.size());//0
  1. 教训:vector操作不熟悉且不是非得用vector时,直接用数组反而不会遇到这么多的问题

code

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

string cards[] = {"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
                  "H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
                  "C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
                  "D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
                  "J1","J2"};
vector<string> v1(54),v2(54);

void initVector()
{
    for(int i = 0; i < 54; i++){
        v1[i] = cards[i]; //注意赋值方式
    }
}

int main()
{
    initVector();
    int k,pos,order[54];
    scanf("%d",&k);
    for(int i = 0; i < 54; ++i){
        scanf("%d",&order[i]);
    }
    while(k--){
        for(int i = 0; i < 54; ++i){
            pos = order[i];
            v2[pos-1] = v1[i]; //使用此法赋值v1,v2必须指定大小
        }
        v1 = v2;
    }
    for(int i = 0; i < 54; ++i){
        cout << v2[i];
        if(i!=53) printf(" ");
    }
    return 0;
}

:(关于vector)

  1. 关于vector间的赋值,assign函数
  2. vector指定位置插入,删除操作
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值