1127 ZigZagging on a Tree (30 分)

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

code

#include<iostream>
#include <bits/stdc++.h>
using namespace std;

struct node
{
    int data, index, level;
    node(int data, int index, int level):data(data), index(index), level(level){}
};

int n;
int in[31];
int post[31];
vector<node> v;

bool cmp(const node &a, const node &b)
{
    if(a.level != b.level) return a.level < b.level;
    if(a.level%2==0) return a.index > b.index;
    return a.index < b.index;
}

void ergodic(int root, int st, int ed, int index, int level)
{
    if(st > ed) return;
    v.push_back(node(post[root], index, level));
    int i = st;
    while(i < ed && in[i] != post[root]) ++i;
    ergodic(root - 1 - (ed - i), st, i - 1, 2*index + 1, level + 1);
    ergodic(root - 1, i + 1, ed, 2*index + 2, level + 1);
}

int main()
{
    scanf("%d",&n);
    for(int i = 0; i < n; ++i){
        scanf("%d",&in[i]);
    }
    for(int i = 0; i < n; ++i){
        scanf("%d",&post[i]);
    }
    ergodic(n - 1, 0, n - 1, 0, 0);
    sort(v.begin(), v.end(), cmp);
    for(int i = 0; i < v.size(); ++i){
        if(i) printf(" ");
        printf("%d", v[i].data);
    }
    return 0;
}

参考自:1127 ZigZagging on a Tree(30 分)——minjiex

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值