1097 Deduplication on a Linked List (25 分)

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

tips

  • 使用两个node的vector存储删除和不删除的输出串,这样当当前key的绝对值访问过时,不需要对该节点进行所谓“删除”操作(即把前面节点的next指向当前结点的next),而是直接放入一个vector ans1中,未访问的结点一样放入一个vector ans2
  • 这样,因为我们是按链表的顺序访问的,因此vector中的结点也是有序的,只需对输出做稍加修改——每一个结点的next输出为下一个结点的address(即对链表进项“删除”操作后该节点的真正next就是它所在vector中的下一个结点的address)
  • 貌似PAT的链表类题目都是这种类型,因此需要注意解决一类题目的特定的技巧

code

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100000;

struct node
{
    int address;
    int key;
    int next;
}List[maxn];

bool vis[10010] = {false};
vector<node> ans1, ans2;

int main()
{
    int start, n;
    scanf("%d%d",&start,&n);
    for(int i = 0; i < n; i++){
        int adr,key,next;
        scanf("%d%d%d",&adr,&key,&next);
        List[adr].address = adr;
        List[adr].key = key;
        List[adr].next = next;
    }
    int adr = start;
    while(adr != -1){
        int value = fabs(List[adr].key);
        if(!vis[value]){
            ans1.push_back(List[adr]);
        }
        else {
            ans2.push_back(List[adr]);
        }
        vis[value] = 1;
        adr = List[adr].next;
    }
    for(int i = 0; i < ans1.size(); i++){
        if(i != ans1.size() - 1)
            printf("%05d %d %05d\n",ans1[i].address, ans1[i].key, ans1[i + 1].address);
        else printf("%05d %d -1\n",ans1[i].address, ans1[i].key);
    }
    for(int i = 0; i < ans2.size(); i++){
        if(i != ans2.size() - 1)
            printf("%05d %d %05d\n",ans2[i].address, ans2[i].key, ans2[i + 1].address);
        else printf("%05d %d -1\n",ans2[i].address, ans2[i].key);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值