HDU 1013 Digital Roots

题目描述:

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3

求解:

解法1:

用int来存输入的数,结果WA了,所以可能是没有考虑到输入的数特别大的问题

//Digital Roots
#include<stdio.h>

int main(){
	
	int n;
	while(scanf("%d",&n) && n){
		
		int sum=n;	
		while(sum>=10){
			sum=0;
			while(n){
				sum+=n%10;
				n=n/10;
			}
			n=sum;
		
		}
		printf("%d\n",sum);
	}
	return 0;
} 
解法2:

用char 数组来存输入的数,开了1000长度时,还是WA,很烦。最后试着开了10000的长度,就AC了,这题。。。也不给说个范围吗?

//Digital Roots
#include<stdio.h>
#include<string.h>

int main(){
	
	char n[10000];
	while(scanf("%s",n) && strcmp(n,"0")){
		
		int len=strlen(n),i;	
	
		while(len>1){
			int sum=0;
			for(i=0;i<len;i++){
				sum+=(n[i]-'0');
			}
			
			i=0;
			while(sum){
				n[i++]=(sum%10+'0');
				sum/=10;
			}
			n[i]='\0';
			len=strlen(n);
		}
		printf("%d\n",n[0]-'0');
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值