POJ - 3278 Catch That Cow



 Catch That Cow


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the pointsX - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.






Sample Input
5 17


Sample Output
4


Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:

已知牛和人的位置,人单位时间只能左或右走一步,或者走现在的两倍距离(在数轴上,且牛不动),问什么时候能追上牛。广搜解决


代码:

//所有情况搜索 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define maxn 100002
using namespace std;
int n,m;
struct data{
	int x,step;
}p;
int vis[100005];
void bfs(){
	queue<data>q;
	p.x=n;
	p.step=0;
	q.push(p);
	vis[n]=1;
	while(!q.empty()){
		p=q.front();
		q.pop();
		if(p.x==m){
			printf("%d\n",p.step);
			return ;
		}
		data k=p;
		if(k.x+1<maxn&&!vis[k.x+1]){
			k.x++;
			vis[k.x]=1;
			k.step++;
			q.push(k);
			
		}
		k=p;
		if(k.x-1>=0&&!vis[k.x-1]){
			k.x--;
			vis[k.x]=1;
			k.step++;
			q.push(k);
		}
		k=p;
		if(k.x*2<maxn&&!vis[k.x*2]){
			k.x*=2;
			vis[k.x]=1;
			k.step++;
			q.push(k);
		}
	}
}
int main(){
	scanf("%d%d",&n,&m);
	memset(vis,0,sizeof(vis));
	bfs();
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值