POJ 1218 THE DRUNK JAILER

THE DRUNK JAILER
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28016 Accepted: 17376

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100

Sample Output

2
10
//本题题意类似于开灯笼,就是每隔一个回合,对该回合倍数的灯笼编号变换一次现场灯笼的开关,问最后还有多少灯笼开着。
//不过可以看作求给定灯笼个数内的完全平方数的个数。比如现在是编号为9=3*3的灯笼,对它的开关产生影响的回合只有1,3,9.因为为1的时候开关为开,那么三次变换9一定是开的.同理,对编号为完全平方数的灯笼产生影响的回合的个数位奇数,最后该编号的灯笼一定是开的。
#include <iostream>
#include <cmath>
using namespace std;
int main(int argc, const char * argv[]) {
    int n;
    cin>>n;
    int i=0;
    int num;
    while(i<n)
    {
        cin>>num;
        int count=0;
        for(int j=1;j<=sqrt(num);j++)
            if(j*j<=num)
                count++;
        cout<<count<<endl;
        i++;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值