POJ 2262 Goldbach's Conjecture

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45475 Accepted: 17311

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers. 

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23. 

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n. 

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong." 

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
//如果直接暴力求解会出现TL,只能采用打表的方式,先把2-1000000的所有素数找出来,根据输入的情况进行判断。题目要求的是差值最大,那么一般情况是素数从小到达遍历,第一种情况就是差值最大的。i最小,n-i最大。
#include <iostream>
using namespace std;
#define MAX 1000010
bool prime[MAX+1];//初始化为0
void judgePrime()//逆向思维寻找素数,将制定范围内的非素数置为1,剩下的就是素数
{//==0是素数
    for(int i=2;i*i<=MAX;i++)
        if(prime[i]==0)
            for(int j=i*i;j<=MAX;j += i)//将制定的数的范围内i的倍数全部置为1
                prime[j]=1;
}
int main()
{
    judgePrime();
    while(1)
    {
        int n;
        scanf("%d",&n);
        if(n==0)
            break;
        for(int i=2;i<=n/2;i++)//从最小值开始遍历
        {
            if(prime[i]==0 && prime[n-i]==0)
            {
                printf("%d = %d + %d\n",n,i,n-i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值