POJ 1032 Parliament

Parliament
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18887 Accepted: 8016

Description

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished. 
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible. 

Input

The input file contains a single integer N (5<=N<=1000 ).

Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces. 

Sample Input

7

Sample Output

3 4

这道题目要求对给定的整数,创造一个全部小于他的数的数列,每个数都不重复,并且数列是递增的。要求最后数列的和为概述本身的同时数列的长度最长。可以用10 举例,从2 开始遍历,2+3+4 当遇到10-(2+3+4)<接下来的这个数时停止,并将1 逆序加给数列的每个元素。最后的结果就是 2 3 5;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;
int result[100]={0};
int n;
int main(int argc, char const *argv[])
{
    int count=0,sum=0;
    scanf("%d",&n);
    for(int i=2;i<n;i++)
    {
        if(n-sum>=i)
        {
            result[count]=i;
            sum+=result[count];
            count++;
        }
        else
        {
            if(n-sum>=count)//如果最后剩余的数大于数列的长度的时候,先给数列的每个元素加一,最后剩余的数逆序加给数列的元素
            {
                for(int k=0;k<count;k++)
                    result[k]=result[k]+1;
                sum+=count;
                result[count-1]+=n-sum;
                sum+=n-sum;
            }
            else
            {
                int k=count-1;
                for (int i = 0; i <n-sum; ++i)
                {
                    result[k]=result[k]+1;
                    k--;
                }
                sum+=n-sum;
            }
        }
        if(sum==n)
            break;
    }
    for(int i=0;i<count;i++)
        cout<<result[i]<<" ";
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值