POJ - 1032 Parliament

Description

New convocation of The Fool Land’s Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.

You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input

The input file contains a single integer N (5<=N<=1000 ).

Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.

Sample Input

7

Sample Output

3 4

一个数分成两个不小于2的数积一定比原数大
一个数分成的两个数越平均越大
因为不可重复所以最优的应该是一个序列2-3-4…
最后可能会有剩下的数
剩下的就从后往前加在每一个数上
从前往后会有重复

代码

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int max_=1000005;
char al[max_];
int main()
{
    int n,m[100];
    while(~scanf("%d",&n))
    {
        int l=0;
        while(n>=l+2)
        {
            m[l]=l+2;
            n-=(l+2);
            ++l;
        }
        int t=l-1;
        while(n)
        {
            m[t--]++;
            --n;
            if(t<0)
                t=l-1;
        }
        for(int i=0;i<l;++i)
        {
            if(i)
                putchar(' ');
            printf("%d",m[i]);
        }
        putchar('\n');
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值