1029 旧键盘 (20分)
旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。
输入格式:
输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。
输出格式:
按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。
输入样例:
7_This_is_a_test
_hs_s_a_es
输出样例:
7TI
很简单的一道题,记得在第一次输出之后记录这样一个已经输出的确认
#include<stdio.h>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<fstream>
using namespace std;
int main() {
freopen("d://in.txt","r",stdin);
char c1[85];
char c2[85];
int as[200] = {0};
scanf("%s%s",c1,c2);
int len1 = strlen(c1);
int len2 = strlen(c2);
for(int ic1 =0; ic1 < len1; ic1++) {
if(c1[ic1]>='a'&&c1[ic1]<='z')
c1[ic1] = c1[ic1] - 'a' + 'A';
}
for(int ic2 =0; ic2 < len2; ic2++) {
if(c2[ic2]>='a'&&c2[ic2]<='z')
c2[ic2] = c2[ic2] - 'a' + 'A';
}
int ic1,jc2;
for(ic1 = 0,jc2=0; ic1<len1&&jc2<len2;) {
if(c1[ic1] != c2[jc2]&&as[c1[ic1]]==0) {
printf("%c",c1[ic1]);
as[c1[ic1]] = 1;
ic1++;
} else if(c1[ic1] != c2[jc2]&&as[c1[ic1]]==1) {
ic1++;
} else {
ic1++;
jc2++;
}
}
while(ic1 < len1) {
if(as[c1[ic1]]==0) {
printf("%c",c1[ic1]);
as[c1[ic1]] = 1;
}
ic1++;
}
printf("\n");
return 0;
}