1046 Shortest Distance (20分)

PAT (Advanced Level) Practice

题目链接.

  • 编程题 1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^​5]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​ , where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​^4​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7.

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

/*********************************************************************************************************************************/

思路:
步骤 1: 以 dis[i] 表示 1 号结点按顺时针方向到达 “i 号结点顺时针方向的下一个节点” 的距离(1 <= i <= N),sum 表示一圈的总距离。于是对每个查询 left --> right,其结果就是 dis(left, right) 与 sum - dis(left, right) 中的较小值。

步骤 2: dis 数组和 sum 在读入时就可以进行累加得到。这样对每个查询 left --> right,dis(left, right) 其实就是 dis[right - 1] - dis[left - 1]。这样可以做到查询复杂度为 O(1)。

注意点:

  1. 查询的两个点的编号可能会有 left > right 的情况。这种情况下,需要交换 left 和 right。
  2. 此题如果没有经过预处理 dis 数组和 sum 的做法会很容易超时。这是因为在极端情况下,每次查询都需要遍历整个数组,即有 10^5 次操作,而共有 10^4 个查询,所以极端情况会有 10^9 次操作,这在 100 ms 的时限内是不能承受的。
  3. 之所以不把 dis[i] 设置为 1 号结点按顺时针方向到达 i 号结点的距离,是因为 N 号结点到达 1 号结点的距离无法被这个数组所保存。

参考代码

#include <cstdio> 
#include <algorithm>
using namespace std;

const int MAXN = 100005;
int dis[MAXN], A[MAXN];	//A[i] 存放 i 号与 i + 1 号顶点的距离
int main() {
	int sum = 0, query, n, left, right;
	scanf ("%d", &n);
	for (int i = 1; i <= n; i++) {
		scanf ("%d", &A[i]);
		sum += A[i];	//累加 sum
		dis[i] = sum;	//预处理 dis 数组 
	}
	scanf ("%d", &query); 
	for (int i = 0; i < query; i++) {	//query 个查询 
		scanf ("%d%d", &left, &right); 	//left --> right
		if (left > right)	swap(left, right);	//left > right 时交换
		int temp = dis[right - 1] - dis[left - 1];
		printf ("%d\n", min(temp, sum - temp));
	}
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值