Tri Tiling

成绩10开启时间2018年03月1日 星期四 00:00
折扣0.8折扣时间2018年12月30日 星期日 23:55
允许迟交关闭时间2018年12月30日 星期日 23:55

Description 
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 
Here is a sample tiling of a 3x12 rectangle.

1 

Input 
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output 
For each test case, output one integer number giving the number of possible tilings.

Sample Input 


12 
-1

Sample Output 

153 
2131

Source 
Waterloo local 2005.09.24

 
        

 

这题我没推出来,我想到了n为2时有三种情况,但往后就不知道怎样递推了。

算了,看了这么多题解,这篇讲的还挺好的,%一发。

http://blog.csdn.net/qq_33557479/article/details/50886653

#include<iostream>
using namespace std;
int x;
int dp[32];

void init()
{
	dp[0] = 1;
	dp[2] = 3;
	for (int i = 4; i <= 30; i+=2)
	{
		dp[i] = 4 * dp[i - 2] - dp[i - 4];
	}
}

int main()
{
	init();
	while (true)
	{
		cin >> x;
		if (x == -1) break;
		cout << dp[x] << endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

水之积也不厚,则其负大舟也无力

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值