Tri Tiling POJ - 2663 (用 1*2的方格 铺 3*n的方格多少种方法,递推)

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 
Here is a sample tiling of a 3x12 rectangle. 
Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.
Output
For each test case, output one integer number giving the number of possible tilings.
Sample Input
2
8
12
-1
Sample Output
3
153
2131

思路:首先可以知道当n为奇数时,一定输出 0,当n 为偶数时,我们把两列看做一个整体,把后两列于前面的分开,因为a[2] = 3,这时候为3*a[n-2]种,当 把 后4列看成一个整体时,后4列不能再分了那么之有2种情况,所以为2*a[n-4]种铺法,后四列可以分开的情况在 前面 3*a[n-2] 中 已经包括了;把后6列看成一个整体,后6列不能再分,也为2种情况(自己看图动手找找是哪两种情况),也为2*a[n-6]种情况,后6列可以分开的情况在前面已经包括了,所以就这样一直 后8列......

所以递推式为 a[n] = 3*a[n-2] + 2*(a[n-4] + a[n-6]+.....+a[0]);

                     a[n-2] = 3*a[n-4] + 2*(a[n-6]...a[0]);

             所以 a[n] = 3*a[n-2] + 2(a[n-4]+ a[n-6]+...+a[0]) + a[n-4] - a[n-4];

                     a[n] = 4*a[n-2]  - a[n-4];

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define ll long long 
int main()
{
	ll a[32];
	memset(a,0,sizeof(a));
	a[0] = 1;
	a[2] = 3;
	for(int i = 4;i<=30;i++)
		a[i] = 4*a[i-2] - a[i-4];
	int n;
	while(~scanf("%d",&n)&&n!=-1)
		printf("%lld\n",a[n]);
	return 0;
} 


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值