POJ 3761 Bubble Sort

Bubble Sort
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2842 Accepted: 982

Description

Bubble sort is a simple sorting algorithm. It works by repeatedly stepping through the list to be sorted, comparing each pair of adjacent items and swapping them if they are in the wrong order. The pass through the list is repeated until no swaps are needed, which indicates that the list is sorted. The algorithm gets its name from the way smaller elements "bubble" to the top of the list. Because it only uses comparisons to operate on elements, it is a comparison sort.
                ­­­­­­­­­­ Wikipedia

Bubble Sort is a very simple sorting algorithm which runs in O(n2) time. Each round, we start from the beginning of the list, compare each adjacent pair of items in turn, swapping the items if necessary. Repeat the pass through the list, until no swaps are done. Assume that after exactly T rounds, the array is already in the ascending order, then we say that T is the number of Bubble Sort Rounds of this array. Below is an example: Let us take an array of numbers "5 1 4 2 8", then we sort the array using Bubble Sort as follow:

First Round:
5 1 4 2 8 ) -> ( 1 5 4 2 8 ), Compares the first two elements, and swaps them.
( 1 5 4 2 8 ) -> ( 1 4 5 2 8 ), Swap since 5 > 4
( 1 4 5 2 8 ) -> ( 1 4 2 5 8 ), Swap since 5 > 2
( 1 4 2 5 8 ) -> ( 1 4 2 5 8 ), since these elements are already in order (8 > 5), algorithm does not swap them.
Second Round:
1 4 2 5 8 ) -> ( 1 4 2 5 8 )
( 1 4 2 5 8 ) -> ( 1 2 4 5 8 ), Swap since 4 > 2
( 1 2 4 5 8 ) -> ( 1 2 4 5 8 )
( 1 2 4 5 8 ) -> ( 1 2 4 5 8 )

After T = 2 rounds, the array is already sorted, hence we say that the number of Bubble Sort Rounds of this array is equal to 2.

ZX learns Bubble Sort in an algorithm class and his teacher leaves him a problem as homework. The teacher gives ZX an array A with N distinct numbers which is already sorted in ascending order and he tells ZX that this array is obtained after exactly K rounds of Bubble sort. The problem is: How many initial arrays there may be from which we can obtain the array A after exactly K rounds of Bubble Sort? The result may be very large, so you only need to output the answer mod 20100713.  

Input

The input may contain several cases.
The first line contains an integer  T ( T ≤ 100,000), indicating the number of test cases.
Then  T lines of test cases follow. For each line, it contains two integers  N and  K (1 ≤  N ≤ 1,000,000, 0 ≤  K ≤  N - 1) where  N is the size of array and  K is the number of Bubble Sort Rounds.

Output

For each line, output an integer which is the number of initial arrays mod 20100713.

Sample Input

3
3 0
3 1
3 2

Sample Output

1
3
2

Hint

Suppose the ordered array is {a, b, c} (a < b < c). For the 6 possible initial arrays:
{a, b, c}, {a, c, b}, {b, a, c}, {b, c, a}, {c, a, b}, {c, b, a},
we can get that:
{a, b, c}: already sorted, no bubble sort needed.
{a, c, b}, {b, a, c}, {c, a, b}: we need 1 round of Bubble Sort.
{b, c, a}, {c, b, a}: we need 2 rounds of Bubble Sort.

大意:题意,求含n个不同元素的排列恰好经过k趟冒泡排序变得有序。问原数组有多少种排列情况

思路:我也是参考了别的大牛的博客才懂的,对于我来说,感觉很难推出来

首先,定义一个反序表f(x)表示在数组中位于元素x左面且大于x的个数。那么,
1,f(x) = 0 (x = 1,2,...,n)是最终有序的状态
2,f(x) <= n - x;
3,对于每趟冒泡排序,若f(x) != 0,则f(x)--;//反序表,最大反序表数就是经过趟数
比较好求的是经过不超过k趟冒泡的排列数g(k)
易知,k趟冒泡达到有序的充要条件是 max f(x) == k
所以 n - x <= k;即 x >= n -  k时,x可以放在数组的任意位置。
把元素分为[1,n-k],[n-k+1,n],在n个位置中放好了前n-k个数后,后k个数的方法为k!
对于前n-k 个数挨个来看,
首先要是f(1) <= k,则1有k+1个位置可放,放好1后,由于1的位置对f(2)无影响,
2同样有k+1个位置可放...
g(k) = (k+1)^(n-k) * k!
最终结果则为 g(k) - g(k-1) = k! * [(k + 1)^(n - k) - k^(n - k)]

上代码:

#include<iostream>
#include<cmath>
#include<cstring>
#include<stack>
#include<cstdio>
#include<string>
#include<vector>
#include<algorithm>
#define M 20010
using namespace std;
#define ll long long 
#define  inf 0x3f3f3f3f
const int maxn = 1000010;
ll a[maxn];
#define mod 20100713
//给出了100个测试数据,n最大1000000,1000ms,故打表比较快
void solve()//阶乘
{
	a[0] = a[1] = 1;
	for (int i = 2; i <= maxn - 10; i++)
		a[i] = a[i - 1] * i%mod;
}
ll multimod(int a, int b)
{
	ll res = 1, tmp = a;
	while (b)
	{
		if (b & 1)
		{
			res *= tmp;
			res %= mod;
		}
		tmp *= tmp;
		tmp %= mod;
		b >>= 1;
	}
	return res;
}
int main()
{
	//freopen("Text.txt", "r", stdin);
	solve();
	int t, n, k;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &k);
		if (k == 0)
		{
			printf("1\n");
			continue;
		}
		ll ans = a[k];
		ll ans1 = a[k];
		ans *= multimod(k + 1, n - k);
		ans %= mod;
		ans += mod;//防止ans比ans1小
		ans1 *= multimod(k, n - k);
		ans1 %= mod;
		ans = (ans - ans1) % mod;
		printf("%lld\n", ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值