在Ubuntu下Qt创建第一个OpenGL项目

1、
OpenGl的环境安装,Qt创建OpenGL所需要依赖的库文件
建立基本编译环境:
首先不可或缺的,就是编译器与基本的函式库,如果系统没有安装的话,请依照下面的方式安装:

$ sudo apt-get install build-essential

安装OpenGL Library
接下来要把我们会用到的 Library 装上去,首先安装 OpenGL Library
$sudo apt-get install libgl1-mesa-dev

安装OpenGL Utilities
OpenGL Utilities 是一组建构于 OpenGL Library 之上的工具组,提供许多很方便的函式,使 OpenGL 更强大且更容易使用。接下来我们安装OpenGL Utilities

$sudo apt-get install libglu1-mesa-dev

安装OpenGL Utility Toolkit
OpenGL Utility Toolkit 是建立在 OpenGL Utilities 上面的工具箱,除了强化了 OpenGL Utilities 的不足之外,也增加了 OpenGL 对于视窗介面支援。

$sudo apt-get install libglut-dev

注意在这一步的时候,可能会出现以下情况,shell提示:正在读取软件包列表… 完成正在分析软件包的依赖关系树 正在读取状态信息… 完成 E: 未发现软件包 libglut-dev如果出现上述情况,请输入将上述sudoaptgetinstalllibglutdevsudo apt-get install libglut-dev命令改成sudo apt-get install freeglut3-dev就行拉

qt程序,需要用到opeg库时,需要在在工程文件中添加:
LIBS += -lglut
LIBS+= -lGLU

另外,需要在ubuntu中按照上述方式安装opengl之后,编译才不会报错。 不知道qmake会去哪里找glut库,自动在整个系统里找吗?

以上OpenGL环境搭建转自:
作者:LIVE FOR YOURSELF
原文:https://blog.csdn.net/qq_35865125/article/details/83042766

2、
如果上面第一步库装好之后Qt OpenGL项目可以正常编译运行则这一步非必须,否则你还需要配置
glew库,参照以下方法:
1.Ubuntu下glfw的安装与使用:https://blog.csdn.net/parry_liu/article/details/73801097
2.Ubuntu上配置编译GLFW并运行实例:https://blog.csdn.net/xyh930929/article/details/83745958
3.E: 您必须在 sources.list 中指定代码源(deb-src) URI 解决办法:
https://blog.csdn.net/weixin_38634889/article/details/97941817

3、
.pro文件
在这里插入图片描述.h文件
注意:#include <GL/glu.h> 头文件很重要,没有的构建是会找不到glu***();这一类函数
在这里插入图片描述.cpp文件
在这里插入图片描述

发布了12 篇原创文章 · 获赞 3 · 访问量 1381
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览