05-树8 File Transfer (25 分)

05-树8 File Transfer (25 分)
We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:
Each input file contains one test case. For each test case, the first line contains N (2≤N≤10
​4
​​ ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2
where I stands for inputting a connection between c1 and c2; or

C c1 c2
where C stands for checking if it is possible to transfer files between c1 and c2; or

S
where S stands for stopping this case.

Output Specification:
For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<stdlib.h>

struct set {/定义两个域,一个贮存数据的值,一个储存与它直接连通的的节点下标
	int data;
	int rootindex;/对于一个根节点来说它的rootindex为负的树高,一个节点的树高定位1
};
typedef struct set SET;
//int Find(SetType S[], int X)
//{ /* 默认集合元素全部初始化为-1 */
//	if (S[X] < 0) /* 找到集合的根 */
//		return X;
//	else
//		return S[X] = Find(S, S[X]); /* 路径压缩 */
//}
int find(int x, SET set[])找到x的根节点并返回其根节点下标
{
	int i;
	for (i = x-1 ; set[i].rootindex >= 0;)
		i = set[i].rootindex;
	return i;
}
void check(SET set[])//检查两个节点的连通性,即判断两个的根节点是不是相同
{
	int x, y;
	scanf("%d%d", &x, &y);
	int root1, root2;
	root1 = find(x, set);
	root2 = find(y, set);
	if (root1 != root2)
		printf("no\n");
	else printf("yes\n");
}
void link(SET set[])将两个未连通的节点连接
{					找到他们的根节点将他们的连接到一起
	int x, y;					///原则将小树连到大树上
	scanf("%d%d", &x, &y);
	int root1, root2;
	root1 = find(x, set);
	root2 = find(y, set);
	if (root1 != root2)
	{
		if (set[root1].rootindex > set[root2].rootindex)/根据其根节点的书高判断
			set[root1].rootindex = root2;
		else if (set[root1].rootindex < set[root2].rootindex)
			set[root2].rootindex = root1;
		else
		{
			set[root2].rootindex = root1;
			set[root1].rootindex--;
		}
	}
}
void putls(SET set[],int N)
{
	int i,count=0;
	for (i = 0; i < N; i++)
	{
		if (set[i].rootindex < 0)count++;
	}
	if (count == 1)printf("The network is connected.");
	else printf("There are %d components.", count);
}
int main()
{
	SET *set;
	char ch;
	int N;
	scanf("%d", &N);
	set = (SET*)malloc(sizeof(SET) * N);
	for (int i = 0; i < N; i++)
	{
		set[i].data = i+1;
		set[i].rootindex = -1;
	}
	do
	{
		scanf("%c", &ch);
		if (ch == 'C')
			check(set);
		else if(ch=='I')
			link(set);
		else if(ch=='S')
			putls(set,N);
	
	} while (ch!='S');
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值