PAT(Advanced)甲级---1004 Counting Leaves (30 分)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<map>
#include<queue>
#include<cmath>
using namespace std;

//1.存储树,找到根结点
//2.层序遍历得到每层的结点
//3.遍历每层结点,统计每层没有孩子结点的结点数


int N, M;
vector<int> tree[105];
int level[105],maxLevel=1;
int num[105];  //每层页结点个数

void levelOrder(int root){
	level[root] = 1;
	queue<int> q;
	q.push(root);
	while (!q.empty()){
		int temp = q.front();
		q.pop();
		for (auto x : tree[temp]){
			level[x] = level[temp] + 1;
			if (level[x] > maxLevel)maxLevel = level[x];
			q.push(x);
		}
	}
}



int main(){
	scanf("%d%d", &N, &M);
	if (N == 0)return 0 ;
	//存储树
	int s, K, c;
	for (int i = 0; i < M; i++){
		scanf("%d", &s);
		scanf("%d", &K);
		for (int j = 0; j < K; j++){
			scanf("%d", &c);
			tree[s].push_back(c);
		}
	}
	levelOrder(1);
	for (int i = 1; i < 100; i++){
		//叶子结点
		if (tree[i].size() == 0&&level[i]!=0){
			num[level[i]] += 1;
		}
	}
	for (int i = 1; i <= maxLevel; i++){
		if (i != 1)printf(" ");
		printf("%d", num[i]);
	}
}
注:

还有种解法是直接记录每层有哪些结点

vector<int> tree[105];
int nowlevel[105];
vector<int> level[100];
int maxLevel = 1;

void levelorder(int root){
	queue<int>q;
	q.push(root);
	nowlevel[root] = 1;
	level[1].push_back(root);
	while (!q.empty()){
		int troot = q.front();
		q.pop();
		for (auto x : tree[troot]){
			nowlevel[x] = nowlevel[troot] + 1;
			if (nowlevel[x]>maxLevel)maxLevel = nowlevel[x];
			level[nowlevel[x]].push_back(x);
			q.push(x);
		}
	}
}

需要注意的是level要开到100,以及MaxLevel初始化要为1,不能是-1,否则只有一层的情况会报错,会卡测试点2。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值