MOOC程序设计与算法练习题——递归#2787算24

样例输入
5 5 5 1
1 1 4 2
0 0 0 0
样例输出
YES
NO

#include <iostream>
#include <cmath>
#define EPS 1e-6
using namespace std;
double a[5];
bool isZero(double x){
	if(fabs(x) <= EPS)
		return true;
	else
		return false;
}
bool count(double a[],int n){
	if(n == 1){//递归出口
		if(isZero(a[0] - 24))
			return true;
		else
			return false;
	}
	double b[5];
	for(int i = 0;i < n-1; ++i){
		for(int j = i + 1;j < n; ++j){
			int m = 0;
			for(int k = 0;k < n; ++k){
				if(k != i && k != j)
					b[m++] = a[k];
			}
			b[m] = a[i] + a[j];
			if(count(b,m+1))
				return true;
			b[m] = a[i] - a[j];
			if(count(b,m+1))
				return true;
			b[m] = a[j] - a[i];
			if(count(b,m+1))
				return true;
			b[m] = a[i] * a[j];
			if(count(b,m+1))
				return true;
			if(!isZero(a[j])){
				b[m] = a[i] / a[j];
				if(count(b,m+1))
					return true;
			}
			if(!isZero(a[i])){
				b[m] = a[j] / a[i];
				if(count(b,m+1))
					return true;
			}
		}
	}
	return false;
}
int main(){
	while(true){
		for(int i = 0;i < 4; ++i)
			cin >> a[i];
		if(a[0] == 0)
			break;
		if(count(a,4))
			cout << "YES" << endl;
		else
			cout << "NO" << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值