POJ1004 Java实现 By VinsmokeFy

Financial Management

Time Limit: 1000MSMemory Limit: 10000K

Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

思路

这道题属于水体,基本思路就是按照题目格式输入12个数,求其平均值并按题中给的格式输出。用Java可以以不同方式来实现。

AC代码

import java.text.DecimalFormat;
import java.util.*;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.BufferedReader;
import java.math.*;
public class Poj1004 {
 public static void main(String[] args) throws Exception{
  BufferedReader in=new BufferedReader(new InputStreamReader(System.in));
  double a;
  double sum=0;
  for(int i=0;i<12;i++){
  a=Double.valueOf(in.readLine());
  sum=sum+a;}
  DecimalFormat d=new DecimalFormat("#0.00");
  System.out.println("$"+d.format(sum/12));//System.out.printf("%.2f",sum/12); 
 }
}

总结

这道题提交了两次,属实不应该,第一次直接输出了sum/12的double格式,由于java的double格式输出整数的话只保留一位小数,而题中的格式为保留两位小数的形式,所以会wa。之后改了一下代码,实现ac。代码中给出了两种可以保留两位小数的方式,都可以ac。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值