PAT Judge (java)

7-15 PAT Judge(25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

思路:

1、建立一个bucket的类,表示学生。

2、输入的时候,要清楚的区分开以下几种情况:未提交的,提交了未通过编译的,提交了通过编译的分数为0的。分数不为0的。

3、因为一个类里边数据有好几个,所以用表排序结合插入排序。

4、输出的时候,区分没有提交的,提交未通过的或通过分数为0的。

 

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class Main {

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		int n = (int) in.nval;
		in.nextToken();
		int k =(int) in.nval;
		in.nextToken();
		int m = (int) in.nval;
		
		int full_score [] = new int [k];
		
		for(int i=0;i<k;i++) {
			in.nextToken();
			full_score[i] = (int) in.nval;
		}	
		Bucket bucket []  = new Bucket[n];
		for(int i=0;i<n;i++)
			bucket[i] = new Bucket(k,i+1);
		
		for(int i=0;i<m;i++) {
			in.nextToken();
			int id = (int) in.nval;
			in.nextToken();
			int pro = (int) in.nval;
			in.nextToken();
			int score = (int) in.nval;

			if(score == full_score[pro-1]&&bucket[id-1].problem[pro-1]!=score) {
				bucket[id-1].num++;
			}
			
			if(bucket[id-1].problem[pro-1]<score) {
				bucket[id-1].problem[pro-1] = score;
				
			}
			if(score>=0)
				bucket[id-1].flag=1;			//只要这个学生提交且编译通过,它就应该最后被展示出来。
		}
		
		for(int i=0;i<n;i++) {
			for(int j=0;j<k;j++) {
				if(bucket[i].problem[j] >-1)
					bucket[i].total+=bucket[i].problem[j];
			}
		}
		/开始表排序
		int key[] = new int [n];
		for(int i=0;i<n;i++)
			key[i] = i;
		
		int  temp ,j=0;
		for(int i = 1;i<n;i++) {
			temp = key[i];
			for( j = i-1;j>=0&&bucket[key[j]].compare(bucket[temp]);j--)
				key[j+1] = key[j];
			key[j+1] = temp;
		}
		
		///最后输出
		int rank= 1;
		int total_score=0;
		int real_rank=0;
		for(int i =n-1;i>=0;i--) {
			int kk = key[i];
			if(bucket[kk].flag==1) {
				
				if(bucket[kk].total!=total_score) {
					System.out.print(rank+" ");
					real_rank = rank;
				}
				else 
					System.out.print(real_rank+" ");
				
				System.out.printf("%05d", bucket[kk].id);
				System.out.print(" "+bucket[kk].total);
				
				for(int p =0;p<k;p++) {
					if(bucket[kk].problem[p]==-2)				//未提交
						System.out.print(" -");
					else if(bucket[kk].problem[p]==-1)			//提交未通过编译
						System.out.print(" 0");
					else
						System.out.print(" "+bucket[kk].problem[p]);
				}
				System.out.println();
	
				rank++;
				total_score = bucket[kk].total;
				
			}
		}
		
	}

}
class Bucket{
	Bucket(int k,int id){
		problem = new int[k];
		for(int i=0;i<k;i++)
			problem[i] =-2;
		this.id = id;
	}
	public boolean compare(Bucket bucket) {
		// TODO Auto-generated method stub
		if(this.total>bucket.total)
			return true;
		else if(this.total ==bucket.total&&this.num>bucket.num)
			return true;
		else if(this.total ==bucket.total&&this.num==bucket.num&&this.id<bucket.id)
			return true;
		else
			return false;
	}
	int id  ;
	int [] problem ;
	int total;
	int num;		//满分的数量
	int flag;		//标记应该被最后展示出来的学生
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值