1017 Queueing at Bank (排序,队列)

1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

思路:

1、模拟真实的银行排队,先把17点01及其以后的点排除,将满足条件的点装入数组,排序。

2、主要关注窗口,建立窗口数组,值为窗口可以开始服务的时间,如果来的人时间比窗口服务时间晚,直接服务,更新窗口的值, 不产生排队时间。如果来的早了,选取窗口最小的值,在那里排队,两者的差值就是排队时间,更新窗口时间。

3、DecimalFormat类四舍五入有点问题,new DecimalFormat("0.0")可以正常的四舍五入保留一位数组,"#.0"就不能正常四舍五入,最好还是跟c一样,采用printf("%.1f",x)来输出。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
import java.math.RoundingMode;
import java.text.DecimalFormat;
import java.util.ArrayList;
import java.util.Comparator;

public class Main2 {
	static int N;
	static int K;

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(
                               new InputStreamReader(System.in)));
		in.nextToken();
		N = (int) in.nval;
		in.nextToken();
		K = (int) in.nval;
		ArrayList<Node> al = new ArrayList<>();
		for (int i = 0; i < N; i++) {
			int hour, min, sec, p;
			in.nextToken();
			hour = (int) in.nval;
			in.nextToken();
			in.nextToken();
			min = (int) in.nval;
			in.nextToken();
			in.nextToken();
			sec = (int) in.nval;
			in.nextToken();
			p = (int) in.nval;
			int time = hour * 60 * 60 + min * 60 + sec;
			if (time <= 17 * 3600) {
				if (p > 60)
					p = 60;
				al.add(new Node(time, p * 60));
			}
		}

		al.sort(new Comparator<Node>() {
			@Override
			public int compare(Node nd1, Node nd2) {
				// TODO Auto-generated method stub
				if (nd1.time > nd2.time)
					return 1;
				else
					return -1;
			}
		});

		int sum = 0;
		int[] window = new int[K];
		for (int i = 0; i < K; i++) {
			window[i] = 8 * 3600;
		}
		
		for (int i = 0; i < al.size(); i++) {
			int temp = Integer.MAX_VALUE;
			int index = -1;
			for (int j = 0; j < K; j++) {
				if (window[j] < temp) {
					index = j;
					temp = window[j];
				}
			}
			if (al.get(i).time >= temp) {
				window[index] = al.get(i).time + al.get(i).p;
			} else {
				sum += temp - al.get(i).time;
				window[index] = window[index] + al.get(i).p;
			}
		}

		if (al.size() == 0)
			System.out.println("0.0");
		else {
			double aver = (double) sum / al.size()/60;
			System.out.printf("%.1f",aver);
		}

	}

}
class Node {
	public Node(int time, int p) {
		this.time = time;
		this.p = p;
	}

	public int time;
	public int p;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值