1147 Heaps (30 分)(最大堆的判断和二叉树的遍历)

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目大意:

给出一个完全二叉树,判断是否为最大堆或者最小堆,或者既不是最大堆也不是最小堆。然后后序遍历输出

思路:

1、设置两个指示位,ismax=1.ismin=1,如果父节点比任意一个子节点大,则不是最小堆,如果父节点比任意一个子节点小,则不是最大堆。

2、后序遍历的非递归实现就是设置标志位,第三次访问的时候输出。


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
import java.util.Stack;

public class Main {

	static int M, N;
	static int[] heap;
	static int flag = 1;

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		M = (int) in.nval;
		in.nextToken();
		N = (int) in.nval;
		for (int i = 0; i < M; i++) {
			heap = new int[N + 1];
			for (int j = 1; j < N + 1; j++) {
				in.nextToken();
				heap[j] = (int) in.nval;
			}
			int ismax = 1, ismin = 1;
			for (int j = 1; j < N + 1; j++) {
				if (2 * j < N + 1) {
					int child = 2 * j;
					if (child + 1 < N + 1 && heap[child] > heap[child + 1])
						child++;
					if (heap[j] > heap[child])
						ismin = 0;
					child = 2 * j;
					if (child + 1 < N + 1 && heap[child] < heap[child + 1])
						child++;
					if (heap[j] < heap[child])
						ismax = 0;
				} else
					break;
			}
			if (ismax == 1)
				System.out.println("Max Heap");
			else if (ismin == 1)
				System.out.println("Min Heap");
			else
				System.out.println("Not Heap");
			// postOrder(1);
			post2();
			flag = 1;
			System.out.println();
		}

	}

	private static void post2() {
		// TODO Auto-generated method stub
		Stack<Integer> st = new Stack<>();
		int root = 1;
		int[] visit = new int[N + 1];
		while (root >= 1 && root < N + 1 || !st.isEmpty()) {
			while (root >= 1 && root < N + 1) {
				st.push(root);
				visit[root] = 1;
				root = root * 2;
			}
			if (!st.isEmpty()) {

				int num = st.peek();
				if (visit[num] == 1) {
					root = 2 * num + 1;
					visit[num] =2;
				} else if (visit[num] == 2) {
					int tmp = st.pop();
					if (flag == 1) {
						System.out.print(heap[tmp]);
						flag = 0;
					} else
						System.out.print(" " + heap[tmp]);
					root = N + 1;
				}

			}
		}

	}

	private static void postOrder(int root) {
		// TODO Auto-generated method stub
		if (2 * root < N + 1)
			postOrder(2 * root);
		if (2 * root + 1 < N + 1)
			postOrder(2 * root + 1);
		if (flag == 1) {
			System.out.print(heap[root]);
			flag = 0;
		} else
			System.out.print(" " + heap[root]);
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值