1015 Reversible Primes (20分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

从末位数开始按进制拆解成单个数字的数组

Queue<Integer> queue = new ConcurrentLinkedQueue<>();
            int k = num;
            while(k != 0) {
                queue.add(k%radix);
                k = k/radix;
            }

将单个数字的数组按进制组合成整个数

            k = 0;
            while(!queue.isEmpty()) {
                k = k*radix + queue.poll();
            }

 

/*
 * Copyright (C) 2020 Baidu, Inc. All Rights Reserved.
 */
package day1;

import java.util.Queue;
import java.util.Scanner;
import java.util.concurrent.ConcurrentLinkedQueue;

public class Main2 {
    public static int MAX = 100001;
    public static int[] prime = new int[MAX];
    public static void main(String[] args) {
        intPrime();
        Scanner scan = new Scanner(System.in);
        while(true) {
            int num = scan.nextInt();
            if (num < 0) {
                break;
            }
            int radix = scan.nextInt();
            if (prime[num] == 1) {
                System.out.println("No");
                continue;
            }
            Queue<Integer> queue = new ConcurrentLinkedQueue<>();
            int k = num;
            while(k != 0) {
                queue.add(k%radix);
                k = k/radix;
            }
            k = 0;
            while(!queue.isEmpty()) {
                k = k*radix + queue.poll();
            }
            if (prime[k] == 0) {
                System.out.println("Yes");
            } else {
                System.out.println("No");
            }
        }
    }

    public static void intPrime() {
        prime[1] = 1;
        for (int i = 2; i < MAX; i++) {
            for (int j = 2; i * j < MAX; j++) {
                prime[i*j] = 1;
            }
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值