Truck History( poj 1789 prim)

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29708 Accepted: 11620

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

CTU Open 2003

原作者讲得非常好非常详细,我没有什么自己的理解好添加的了。题意是求卡车之间的最小的派生关系距离之和,即最小生成树,用的是prim算法,查一下就知道是什么了。
    #include <stdio.h>  
    #include <string.h>  
    #include <stdlib.h>  
    #define inf 99999999  
    int map[2010][2010];  
    char str[2010][10];  
    int dis[2010];//记录边的权值  
    int flag[2010];//记录是否被访问  
    int find(int a,int b)  
    {  
        int i;  
        int count=0;  
        for(i=0;i<7;i++)  
            {  
                if(str[a][i]!=str[b][i])  
        {  
            count++;  
        }  
            }  
        return count;  
    }  
    int prim(int n)  
    {  
        int max,i,j,k,sum=0;  
        memset(flag,0,sizeof(flag));  
        for(i=0;i<n;i++)  
            dis[i]=map[0][i];  
        flag[0]=1;//零点标记为已经访问  
        for(i=1;i<n;i++)//进行n-1次操作  
        {  
            max=inf;//初始化  
            for(j=1;j<n;j++)//遍历所有点  
            if(max>dis[j]&&!flag[j])//在所有未加入的点中找一个最小的权值  
            {  
                k=j;//记录下标  
                max=dis[j];//更新最小值  
            }  
            if(max==inf)//若图是不连通的  
                break;//提前退出  
            flag[k]=1;  
            sum+=max;  
            for(j=1;j<n;j++)//遍历所有的点  
                if(dis[j]>map[k][j]&&!flag[j])//对未加入的点,找到与此点相连且权值最小的边
                dis[j]=map[k][j];//进行更新  
        }  
        printf("The highest possible quality is 1/%d.\n",sum);  
    }  
      
    int main()  
    {  
        int n,i,j;  
      
        while (~scanf("%d",&n))  
        {  
            memset(map,0,sizeof(map));  
            memset(str,0,sizeof(str));  
            if(n==0)  
                break;  
            for(i=0;i<n;i++)  
                scanf("%s",str[i]);  
                for(i=0;i<n;i++)  
                    for(j=0;j<i;j++)  
                    map[i][j]=map[j][i]=find(i,j);  
                prim(n);  
        }  
        return 0;  
      
    }  
转载地址:http://blog.csdn.net/u013486414/article/details/38341035

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值