POJ1094 拓扑排序

POJ1094 拓扑排序

先上题目

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

思路

大体思路是拓扑排序,但是因为题目要求要确定是多少条不等式得出结论,所以每读入一条不等式就要进行一次判断,由此决定了,第一,检查出有环,即可结束判断,第二,无序只能最后判断。或者,当然,如果不等式的个数小于符号个数-1也可判断。

上代码

#include<iostream>
#include<cstring>

using namespace std;

int map[26][26],q[26],indegree[26];

int TopoSort(int n){
	int temp[26],flag = 1,c = 0;
	for(int i = 0;i<n;i++){
		temp[i] = indegree[i];
	}
	for(int i = 0;i<n;i++){   
		int m = 0,loc;
		for(int j = 0;j<n;j++){
			if(temp[j]==0){
				m++;       
				loc = j;  
			}
		}
		if(m==0) return 0;  //有环
		if(m>1) flag = -1;   //无序仍要继续判断,因为可能后面会有环
		q[c++] = loc;
		temp[loc] = -1;  //使该节点退出上述循环检查
		for(int j = 0;j<n;j++){
			if(map[loc][j])
				temp[j]--;
		} 
	}
	return flag;  
}

int main(void){
	int n,m;
	int sign;
	char str[5];
	while(scanf("%d%d",&n,&m)){
		if(n==0&&m==0) break;
		sign = 0;
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		for(int j = 1;j<=m;j++){
			scanf("%s",str);
			if(m<n-1){
				cout<<"Sorted sequence cannot be determined."<<endl;
				continue;
			}
			if(sign) continue; //已得出判断,继续读完接来下的不等式
			int x = str[0] - 'A';
			int y = str[2] - 'A';
			map[x][y] = 1;
			indegree[y]++; 
			int s = TopoSort(n); 
			if(s==0){
				printf("Inconsistency found after %d relations.\n",j);
				sign = 1;
			}
			if(s==1){
				printf("Sorted sequence determined after %d relations: ",j);
				for(int i = 0;i<n;i++){
					printf("%c",q[i]+'A');
				}
				printf(".\n");
				sign = 1;
			}
			
		}
		if(!sign){
			cout<<"Sorted sequence cannot be determined."<<endl;
		}
		
	} 
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值