【UVA548】Tree 建树+深搜 (2/1000)

Description

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output

1
3
255

很直白的一道题,给你一个中序遍历和后序遍历,问你到叶节点路径的权值最小的叶节点的权值,(路径的权值就是每个节点的权值加起来),如果有多条路径的权值相等,则输出叶节点权值最小的叶节点的权值,好绕。

思路倒很直观,建一个树,然后就深搜,好吧,就是一道水题。。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<sstream>

using namespace std;

const int N=10000+10;
struct node{
    int left;
    int right;
    int weight;
}tree[N];
string str;
int n,x,root,ans,sum=0,tmp=0x3f3f3f3f;
int in[N],post[N];


int build(int l1,int r1,int l2,int r2){
    if (l1>r1) return 0;

    int tmp=post[r2],pos=0;
    for(int i=l1;i<=r1;i++){
        if (in[i]==tmp){
            pos=i;
            break;
        }
    }
    int len=pos-l1;
    tree[pos].left=build(l1,pos-1,l2,l2+len-1);
    tree[pos].right=build(pos+1,r1,l2+len,r2-1);
    tree[pos].weight=in[pos];
    return pos;
}

void dfs(int cur){
    sum+=tree[cur].weight;
    if (tree[cur].left==0&&tree[cur].right==0){
        if ((sum<tmp)||(sum==tmp&&tree[cur].weight<ans)){
            tmp=sum;
            ans=tree[cur].weight;
        }
    }
    if (tree[cur].left) dfs(tree[cur].left);
    if (tree[cur].right) dfs(tree[cur].right);
    sum-=tree[cur].weight;
}

int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    while(getline(cin,str)){
        tmp=0x3f3f3f3f;
        sum=0;
        memset(tree,0,sizeof(tree));

        n=1;
        stringstream ss(str);
        while(ss>>x){
            in[n]=x;
            n++;
        }
        getline(cin,str);
        n=1;
        stringstream ss1(str);
        while(ss1>>x){
            post[n]=x;
            n++;
        }
        root=build(1,n-1,1,n-1);
        dfs(root);
        cout<<ans<<endl; 
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值