机试刷题:PAT A 1034 Head of a Gang 自动去重无向图构建和BFS方法解析

PAT A 1034 Head of a Gang 题目

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:
For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:
2
AAA 3
GGG 3

Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:
0

题目分析

该题希望我们通过给定的(点,点,值)组合来构建无向图,并统计连通分量的个数,同时需要输出连通分量中的“老大”和连通分量中点的个数,且“老大”是该连通分量的所有点中,与该点相连的边权之和最大的点。需要注意的是(A, B, val)与(B, A, val)可以同时作为输入数据出现,且最终输出要按字典序升序输出。为避免顶点重复输入到无向图中,可以选择用unordered_set<>配合map<>构建邻接表达到自动去重的效果。另外,unordered_set<>可以免去set<>自动排序带入的O(logN)的时间消耗。

自动去重邻接表和bfs

#include<bits/stdc++.h>

using namespace std;
int N, K;
map<string, unordered_set<string> > g;
map<string, int> w; //记录每个顶点的边权和,以及当作visit数组使用
vector<pair<string, int> > v;
int cnt, allw;
queue<string> q;

void bfs(pair<string, int> &pa)
{
    int maxw = 0;
    while(!q.empty()){
        string t = q.front();
        if(w[t] > 0){
            pa.second++;
            allw += w[t];
            if(w[t] > maxw){
                maxw = w[t];
                pa.first = t;
            }
            w[t] = 0;
        }
        q.pop();
        for(auto it=g[t].begin(); it!=g[t].end(); it++){
            if(w[*it] != 0){
                q.push(*it);
            }
        }
    }
}

int main()
{
    string a, b;
    int c;
    cin>>N>>K;
    while(N-- > 0){
        cin>>a>>b>>c;
        if(g.find(a) == g.end()){
            unordered_set<string> se;
            g[a] = se;
            w[a] = 0;
        }
        if(g.find(b) == g.end()){
            unordered_set<string> se;
            g[b] = se;
            w[b] = 0;
        }
        g[a].insert(b);
        g[b].insert(a);
        w[a] += c; //在输入时就统计每个顶点的边权和,后续就不需要求和了
        w[b] += c;
    }
    for(auto it=g.begin(); it!=g.end(); it++){
        if(w[it->first] != 0){
            allw = 0;
            q.push(it->first);
            pair<string, int> pa;
            pa.second = 0;
            bfs(pa);
            allw /= 2; //统计边权和的时候,因为无向图A-B与B-A会计算两次边权和,所以这里需要/2修正
            if(allw > K && pa.second > 2){
                v.push_back(pa);
                cnt++;
            }
        }
    }

    cout<<cnt<<endl;
    sort(v.begin(), v.end());
    for(int i=0; i<cnt; i++){
        cout<<v[i].first<<" "<<v[i].second<<endl;
    }
    return 0;
}

感谢您的阅读!如有错误还望告知 😃

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值