机试刷题:PAT A 1155 Heap Paths “假设法”判断递增递减

PAT A 1155 Heap Paths题目

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50

Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:
8
8 38 25 58 52 82 70 60

Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:
8
10 28 15 12 34 9 8 56

Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目分析

本题根据题中给出的“One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.”来判断一个完全二叉树是大顶堆、小顶堆或者不是堆。其实就是判断所有从根结点出发到叶结点的路径上所有值是否是:“非递减”或者“非递增”。如果都是,则是大/小顶堆;否则不是堆。问题就在于如何判断,这里给出“假设法”:先设置两个假设,用布尔变量设置为manh和minh,且初值均为1,表示假设同时是大顶堆和小顶堆。然后只要在后面dfs抵达叶结点输出路径的时候,判断整个路径上是否有不满足假设的情况,有则假设不成立,置maxh/minh=0。而且由于&&判断的“短路性“,只要假设不成立,判断假设的 if 语句不会执行,提高了效率。

“假设法”判断大/小顶堆

#include<iostream>
#include<vector>
#define maxn 1010
using namespace std;
int tree[maxn];
bool maxh = 1, minh = 1; //设置假设
int n, res; //res指示完全二叉树的三种情况
vector<int> path;

void dfs(int root)
{
    int a = root*2, b = a + 1;
    path.push_back(tree[root]);
    if(b <= n) dfs(b);
    if(a <= n) dfs(a);
    if(a > n && b > n){
        for(int i=0; i<path.size(); i++){
            if(i != 0){
                cout<<" ";
                if(maxh && path[i] > path[i-1]) maxh = 0; //判断假设是否成立
                if(minh && path[i] < path[i-1]) minh = 0;
            }
            cout<<path[i];
        }
        cout<<endl;
        if(maxh) res = 1;
        else if(minh) res = -1;
        else res = 0;
    }
    path.pop_back(); //dfs输出多条路径的常用套路
}

int main()
{
    cin>>n;
    for(int i=1; i<=n; i++){
        cin>>tree[i];
    }
    dfs(1);
    if(res == 1) cout<<"Max Heap";
    else if(res == -1) cout<<"Min Heap";
    else cout<<"Not Heap";
}

感谢您的阅读!如有错误还望告知 😃

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值