poj 2893 M × N Puzzle(M*N数码解的判定,使用逆序对)

ACM题集:https://blog.csdn.net/weixin_39778570/article/details/83187443
链接:http://poj.org/problem?id=2893
M × N Puzzle
Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 4681 Accepted: 1269
Description

The Eight Puzzle, among other sliding-tile puzzles, is one of the famous problems in artificial intelligence. Along with chess, tic-tac-toe and backgammon, it has been used to study search algorithms.

The Eight Puzzle can be generalized into an M × N Puzzle where at least one of M and N is odd. The puzzle is constructed with MN − 1 sliding tiles with each a number from 1 to MN − 1 on it packed into a M by N frame with one tile missing. For example, with M = 4 and N = 3, a puzzle may look like:

1 6 2
4 0 3
7 5 9
10 8 11
Let’s call missing tile 0. The only legal operation is to exchange 0 and the tile with which it shares an edge. The goal of the puzzle is to find a sequence of legal operations that makes it look like:

1 2 3
4 5 6
7 8 9
10 11 0
The following steps solve the puzzle given above.

START

1 6 2
4 0 3
7 5 9
10 8 11
DOWN

1 0 2
4 6 3
7 5 9
10 8 11
LEFT

1 2 0
4 6 3
7 5 9
10 8 11
UP

1 2 3
4 6 0
7 5 9
10 8 11

RIGHT

1 2 3
4 0 6
7 5 9
10 8 11
UP

1 2 3
4 5 6
7 0 9
10 8 11
UP

1 2 3
4 5 6
7 8 9
10 0 11
LEFT

1 2 3
4 5 6
7 8 9
10 11 0
GOAL

Given an M × N puzzle, you are to determine whether it can be solved.

Input

The input consists of multiple test cases. Each test case starts with a line containing M and N (2 ≤ M, N ≤ 999). This line is followed by M lines containing N numbers each describing an M × N puzzle.

The input ends with a pair of zeroes which should not be processed.

Output

Output one line for each test case containing a single word YES if the puzzle can be solved and NO otherwise.

Sample Input

3 3
1 0 3
4 2 5
7 8 6
4 3
1 2 5
4 6 9
11 8 10
3 7 0
0 0
Sample Output

YES
NO

题意:m*n大小的奇数码有解判定
题解:
当N为奇数时,上下每交换一次逆序数改变偶次数,左右交换不变,目标逆序数为0,所以只要起始逆序数为偶数就行(划到终点也为偶数,即目标局面的逆序数为偶数)
当N为偶数时,上下每交换一次逆序数改变奇次数,左右交换不变,目标逆序数为0,所以当0那一行离最低行(0最后在最低行)的行距+逆序对数为偶数就行(即两者奇偶性相同)

#include<cstdio> 
#include<iostream>
#define ll long long
#define fo(i,j,n) for(register int i=j; i<=n; ++i)
using namespace std;
const int maxn = 1e6+5;
int n,m,N;
int a[maxn],buf[maxn],cnt;
inline void merge(int L,int R,int mid){
	int i=L,j=mid+1;
	fo(k,L,R){
		if(j>R || i<=mid&&a[i]<a[j])buf[k]=a[i++];
		else buf[k]=a[j++],cnt+=mid-i+1;
	}
	fo(k,L,R)a[k]=buf[k];
}
void MergeSort(int L,int R){
	if(L>=R)return;
	int mid = (L+R)>>1;
	MergeSort(L,mid);
	MergeSort(mid+1,R);
	merge(L,R,mid);
}
int main(){
	while(scanf("%d%d",&m,&n)&&(n||m)){
		N = m*n;
		int x,linex=0,k=0;
		fo(i,1,m)fo(j,1,n){
			scanf("%d",&x);
			if(x==0)linex=m-i;
			else a[++k]=x;
		}
		cnt = 0;
		MergeSort(1,k);
	//	fo(i,1,k)cout<<a[i]<<" ";
	
		if(n&1){ // 每行变换偶对 
			if(cnt&1)puts("NO");
			else puts("YES");
		}else{ // 每行变换奇对 
			if((linex^cnt)&1) puts("NO"); // 奇的话,^ 0,1为1 
			else puts("YES");
		} 

	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值