1.1实验任务
配置交换机的优先级,实现网络的负载分担,并配置骨干交换机之间的EhternetChannel
1.2试验环境和网络拓扑
1.3完成标准
(1)按照拓扑图连接交换机。
(2)在交换机上配置VLAN,启用STP,实现不同的VLAN选择不同的根网桥,实现负载分担。
(3)在接入交换机上配置上行速链路。
(4)配置接入交换机连接主机的端口为速端口。
(5)在两台核心交换机之间配置以太网通道。
2.详细操作步骤
Step 1:在交换机上添加VLAN
在交换机A、B、C和D上添加VLAN 2、3、4
配置各交换机之间连接的接口为Trunk模式
交换机A配置如下:
A#conf t
Enter configuration commands, one per line.End with CNTL/Z.
A(config)#interface range f0/1 - 2
A(config-if-range)#switchport mode trunk//配置端口1~2为中继
A(config-if-range)#
*Mar1 00:04:01.611: %DTP-5-TRUNKPORTON: Port Fa0/1-2 has become dot1q trunk
A(config-if-range)#interface range f0/10 – 11//配置端口11~12为中继
A(config-if-range)#switchport mode trunk
A(config-if-range)#
*Mar1 00:04:36.191: %DTP-5-TRUNKPORTON: Port Fa0/10-11 has become dot1q trunk
A(config-if-range)#exit
A(config)#exit
A#
A#vlan database
A(vlan)#vtp domain 2t57//配置VTP域为2t57
Changing VTP domain name from NULL to 2t57
A(vlan)#vtp server
Device mode already VTP SERVER.//配置VTP模式为Server
A(vlan)#exit
APPLY completed.
Exiting....
A#
A#vlan database
A(vlan)#vlan 2 name VLAN2
VLAN 2 added:
Name: VLAN2
A(vlan)#vlan 3 name VLAN3
VLAN 3 added:
Name: VLAN3
A(vlan)#vlan 4 name VLAN4
VLAN 4 added:
Name: VLAN4
A(vlan)#exit
APPLY completed.//添加VLAN 2、3、4
Exiting....
A#
A#show vlan-s
VLAN NameStatusPorts
---- -------------------------------- --------- -------------------------------
1defaultactiveFa0/0, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/12, Fa0/13, Fa0/14, Fa0/15
2VLAN2active
3VLAN3active
4VLAN4active
1002 fddi-defaultactive
1003 token-ring-defaultactive
1004 fddinet-defaultactive
1005 trnet-defaultactive
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1enet1000011500-----10021003
2enet1000021500-----00
3enet1000031500-----00
4enet1000041500-----00
1002 fddi1010021500-----11003
1003 tr101003150010050--srb11002
1004 fdnet 1010041500--1ibm-00
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1005 trnet 1010051500--1ibm-00
A#
A#show interface f0/1 switchport//查看端口1
Name: Fa0/1
Switchport: Enabled//端口开启
Administrative Mode: trunk//管理模式:中继
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q//管理中继封装:802.1Q
Operational Trunking Encapsulation: dot1q//运行中继封装:802.1Q
Negotiation of Trunking: Disabled//中继协商:未开启
Access Mode VLAN: 0 ((Inactive))//VLAN通过模式:0(非活动)
Trunking Native Mode VLAN: 1 (default)//本地VLAN中继模式:1(默认)
Trunking VLANs Enabled: ALL//多VLAN中继开启:所有
Trunking VLANs Active: 1-4//活动的中继多VLAN:1-4
Priority for untagged frames: 0//未标记的帧优先级:0
Override vlan tag priority: FALSE//超量标记帧优先级:错误
Voice VLAN: none//语音VLAN:无
Appliance trust: none//信任的运行:无
A#show interface f0/2 switchport//查看端口2
Name: Fa0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
A#show interface f0/10 switchport//查看端口10
Name: Fa0/10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
A#show interface f0/11 switchport//查看端口11
Name: Fa0/11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
交换机B配置如下:
B#conf t
Enter configuration commands, one per line.End with CNTL/Z.
B(config)#interface range f0/1 – 2//配置端口1-2为中继
B(config-if-range)#switchport mode trunk
B(config-if-range)#
*Mar1 00:05:18.543: %DTP-5-TRUNKPORTON: Port Fa0/1-2 has become dot1q trunk
B(config-if-range)#interface range f0/10 – 11//配置端口10-11为中继
B(config-if-range)#switchport mode trunk
B(config-if-range)#
*Mar1 00:05:45.963: %DTP-5-TRUNKPORTON: Port Fa0/10-11 has become dot1q trunke
xit
B(config)#exit
B#
B#vlan database
B(vlan)#vtp domain 2t57//配置VTP域名为2t57
Domain name already set to 2t57 .
B(vlan)#exit
APPLY completed.
Exiting....
B#
B#show vlan-s
VLAN NameStatusPorts
---- -------------------------------- --------- -------------------------------
1defaultactiveFa0/0, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/12, Fa0/13, Fa0/14, Fa0/15
2VLAN2active
3VLAN3active
4VLAN4active//VTP同步VLAN成功
1002 fddi-defaultactive
1003 token-ring-defaultactive
1004 fddinet-defaultactive
1005 trnet-defaultactive
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1enet1000011500-----10021003
2enet1000021500-----00
3enet1000031500-----00
4enet1000041500-----00
1002 fddi1010021500-0---11003
1003 tr101003150010050--srb11002
1004 fdnet 1010041500--1ibm-00
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1005 trnet 1010051500--1ibm-00
B#
B#show interface f0/1 switchport//查看端口1
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
B#show interface f0/2 switchport//查看端口2
Name: Fa0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
B#show interface f0/10 switchport//查看端口10
Name: Fa0/10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
B#show interface f0/11 switchport//查看端口11
Name: Fa0/11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
交换机C配置如下:
C#conf t
Enter configuration commands, one per line.End with CNTL/Z.
C(config)#interface range f0/10 – 11//配置端口10-11为中继
C(config-if-range)#switchport mode trunk
C(config-if-range)#
*Mar1 00:06:14.191: %DTP-5-TRUNKPORTON: Port Fa0/10-11 has become dot1q trunk
C(config-if-range)#exit
C(config)#exit
C#
C#vlan d
C(vlan)#vtp domain 2t57//配置VTP域名为2t57
Domain name already set to 2t57 .
C(vlan)#vtp client//配置VTP为客户模式
Setting device to VTP CLIENT mode.
C(vlan)#exit
In CLIENT state, no apply attempted.
Exiting....
C#show vlan-s
VLAN NameStatusPorts
---- -------------------------------- --------- -------------------------------
1defaultactiveFa0/0, Fa0/1, Fa0/2, Fa0/3
Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/12, Fa0/13
Fa0/14, Fa0/15
2VLAN2active
3VLAN3active
4VLAN4active//VTP同步VLAN成功
1002 fddi-defaultactive
1003 token-ring-defaultactive
1004 fddinet-defaultactive
1005 trnet-defaultactive
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1enet1000011500-----10021003
2enet1000021500-----00
3enet1000031500-----00
4enet1000041500-----00
1002 fddi1010021500-0---11003
1003 tr101003150010050--srb11002
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1004 fdnet 1010041500-- 1ibm-00
1005 trnet 1010051500--1ibm-00
C#
C#show interface f0/10 switchport//查看端口10
Name: Fa0/10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
C#show interface f0/11 switchport//查看端口11
Name: Fa0/11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
交换机D配置如下:
D#conf t
Enter configuration commands, one per line.End with CNTL/Z.
D(config)#interface range f0/10 – 11//配置端口10-11为中继
D(config-if-range)#switchport mode trunk
D(config-if-range)#e
*Mar1 00:06:41.843: %DTP-5-TRUNKPORTON: Port Fa0/10-11 has become dot1q trunkx
it
D(config)#exit
D#
D#vlan d
D(vlan)#vtp domain 2t57//配置VTP域名为2t57
Domain name already set to 2t57 .
D(vlan)#vtp client//配置VTP为客户模式
Setting device to VTP CLIENT mode.
D(vlan)#exit
In CLIENT state, no apply attempted.
Exiting....
D#show vlan-s
VLAN NameStatusPorts
---- -------------------------------- --------- -------------------------------
1defaultactiveFa0/0, Fa0/1, Fa0/2, Fa0/3
Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/12, Fa0/13
Fa0/14, Fa0/15
2VLAN2active
3VLAN3active
4VLAN4active//VTP同步VLAN成功
1002 fddi-defaultactive
1003 token-ring-defaultactive
1004 fddinet-defaultactive
1005 trnet-defaultactive
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1enet1000011500-----10021003
2enet1000021500-----00
3enet1000031500-----00
4enet1000041500-----00
1002 fddi1010021500-0---11003
1003 tr101003150010050--srb11002
VLAN TypeSAIDMTUParent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1004 fdnet 1010041500--1ibm-00
1005 trnet 1010051500--1ibm-00
D#
D#show interface f0/10 switchport
Name: Fa0/10//查看端口10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
D#show interface f0/11 switchport//查看端口11
Name: Fa0/11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk//运行模式:中继
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-4
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Step 2:配置根网桥
(1)配置交换机A为VLAN 1和2的根网桥
交换机A配置如下:
A#conf t
Enter configuration commands, one per line.End with CNTL/Z.
A(config)#spanning-tree vlan 1 root primary//配置成为VLAN1的根网桥
% This switch is already the root of VLAN1 spanning tree
//这个交换机已经是VLAN1生成树的根网桥
VLAN 1 bridge priority set to 8192//VLAN1网桥优先级设置为8192
VLAN 1 bridge max aging time unchanged at 20//VLAN1网桥最大生存时间20不变
VLAN 1 bridge hello time unchanged at 2//VLAN1网桥握手时间2不变
VLAN 1 bridge forward delay unchanged at 15//VLAN1网桥转发延迟15不变
A(config)#spanning-tree vlan 2 root primary//配置成为VLAN2的根网桥
% This switch is already the root of VLAN2 spanning tree
//这个交换机已经是VLAN2生成树的根网桥
VLAN 2 bridge priority set to 8192
VLAN 2 bridge max aging time unchanged at 20
VLAN 2 bridge hello time unchanged at 2
VLAN 2 bridge forward delay unchanged at 15
A(config)#exit
A#
*Mar1 00:20:38.031: %SYS-5-CONFIG_I: Configured from console by console
A#show spa brief//查看交换机A生成树信息
VLAN1//VLAN1
Spanning tree enabled protocol ieee//生成树开启的协议ieee
Root IDPriority8192//根网桥优先级8192
Addresscc00.0d08.0000//地址cc00.0d08.0000
This bridge is the root//这个网桥是根网桥
Hello Time2 secMax Age 20 secForward Delay 15 sec
//握手时间2秒最大生存期20秒转发延迟15秒
Bridge IDPriority8192//网桥ID优先级8192
Addresscc00.0d08.0000//地址cc00.0d08.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
//握手时间2秒最大生存期20秒转发延迟15秒
Aging Time 300//生存期300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0000 128.2
FastEthernet0/2128.312819 FWD08192 cc00.0d08.0000 128.3
FastEthernet0/10128.1112819 FWD08192 cc00.0d08.0000 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.0d08.0000 128.12
//根网桥上所有端口均为指定端口,所有端口状态:转发
VLAN2
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.0d08.0001
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority8192
Addresscc00.0d08.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0001 128.2
FastEthernet0/2128.312819 FWD08192 cc00.0d08.0001 128.3
FastEthernet0/10128.1112819 FWD08192 cc00.0d08.0001 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.0d08.0001 128.12
VLAN3
Spanning tree enabled protocol ieee
Root IDPriority32768
Addresscc00.0d08.0002
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768
Addresscc00.0d08.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD0 32768 cc00.0d08.0002 128.2
FastEthernet0/2128.312819 FWD0 32768 cc00.0d08.0002 128.3
FastEthernet0/10128.1112819 FWD0 32768 cc00.0d08.0002 128.11
FastEthernet0/11128.1212819 FWD0 32768 cc00.0d08.0002 128.12
VLAN4
Spanning tree enabled protocol ieee
Root IDPriority32768
Addresscc00.0d08.0003
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768
Addresscc00.0d08.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD0 32768 cc00.0d08.0003 128.2
FastEthernet0/2128.312819 FWD0 32768 cc00.0d08.0003 128.3
FastEthernet0/10128.1112819 FWD0 32768 cc00.0d08.0003 128.11
FastEthernet0/11128.1212819 FWD0 32768 cc00.0d08.0003 128.12
(2)配置交换机B VLAN3~4的优先级为8192
交换机B配置如下:
B#conf t
Enter configuration commands, one per line.End with CNTL/Z.
B(config)#spanning-tree vlan 3 priority 8192//配置VLAN3网桥优先级为8192
B(config)#spanning-tree vlan 4 priority 8192//配置VLAN4网桥优先级为8192
B(config)#exit
B#
*Mar1 00:22:19.671: %SYS-5-CONFIG_I: Configured from console by console
B#show spa brief
VLAN1
Spanning tree enabled protocol ieee
Root IDPriority8192//根网桥优先级8192
Addresscc00.0d08.0000
Cost19//根路径成本19
Port2 (FastEthernet0/1)//端口2(FastEthernet0/1)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768//网桥优先级32768
Addresscc00.1444.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0000 128.2
FastEthernet0/2128.312819 BLK08192 cc00.0d08.0000 128.3
FastEthernet0/10128.1112819 FWD19 32768 cc00.1444.0000 128.11
FastEthernet0/11128.1212819 FWD19 32768 cc00.1444.0000 128.12
//端口2被阻塞
VLAN2
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.0d08.0001
Cost19
Port2 (FastEthernet0/1)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768
Addresscc00.1444.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0001 128.2
FastEthernet0/2128.312819 BLK08192 cc00.0d08.0001 128.3
FastEthernet0/10128.1112819 FWD19 32768 cc00.1444.0001 128.11
FastEthernet0/11128.1212819 FWD 19 32768 cc00.1444.0001 128.12
//端口2被阻塞
VLAN3
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.1444.0002
This bridge is the root//成为VLAN3的根网桥
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority8192
Addresscc00.1444.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.1444.0002 128.2
FastEthernet0/2128.312819 FWD08192 cc00.1444.0002 128.3
FastEthernet0/10128.1112819 FWD08192 cc00.1444.0002 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.1444.0002 128.12
//根网桥上所有端口均为指定端口,所有端口状态:转发
VLAN4//成为VLAN4的根网桥
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.1444.0003
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority8192
Addresscc00.1444.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.1444.0003 128.2
FastEthernet0/2128.312819 LRN08192 cc00.1444.0003 128.3
FastEthernet0/10128.1112819 FWD 08192 cc00.1444.0003 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.1444.0003 128.12
//根网桥上所有端口均为指定端口,所有端口状态:转发
交换机A配置如下:
A#show spa brief
VLAN1
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.0d08.0000
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority8192
Addresscc00.0d08.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0000 128.2
FastEthernet0/2128.312819 FWD08192 cc00.0d08.0000 128.3
FastEthernet0/10128.1112819 FWD08192 cc00.0d08.0000 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.0d08.0000 128.12
VLAN2
Spanning tree enabled protocol ieee
Root ID Priority8192
Addresscc00.0d08.0001
This bridge is the root
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority8192
Addresscc00.0d08.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.0d08.0001 128.2
FastEthernet0/2128.312819 FWD08192 cc00.0d08.0001 128.3
FastEthernet0/10128.1112819 FWD08192 cc00.0d08.0001 128.11
FastEthernet0/11128.1212819 FWD08192 cc00.0d08.0001 128.12
VLAN3
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.1444.0002
Cost19
Port2 (FastEthernet0/1)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768
Addresscc00.0d08.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.1444.0002 128.2
FastEthernet0/2128.312819 BLK08192 cc00.1444.0002 128.3
FastEthernet0/10128.1112819 FWD19 32768 cc00.0d08.0002 128.11
FastEthernet0/11128.1212819 FWD19 32768 cc00.0d08.0002 128.12
VLAN4
Spanning tree enabled protocol ieee
Root IDPriority8192
Addresscc00.1444.0003
Cost19
Port2 (FastEthernet0/1)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority32768
Addresscc00.0d08.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1128.212819 FWD08192 cc00.1444.0003 128.2
FastEthernet0/2128.3 12819 BLK08192 cc00.1444.0003 128.3
FastEthernet0/10128.1112819 FWD19 32768 cc00.0d08.0003 128.11
FastEthernet0/11128.1212819 FWD19 32768 cc00.0d08.0003 128.12
Step 3:配置以太网通道
配置交换机A与B之间的以太网通道
交换机A配置如下:
A#conf t
Enter configuration commands, one per line.End with CNTL/Z.
A(config)#interface range f0/1 – 2//端口1和2
A(config-if-range)#channel-group 1 mode on//以太通道1模式开启
Creating a port-channel interface Port-channel1//创建一个以太通道Port-channel1
A(config-if-range)#
*Mar1 00:25:57.543: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po1
*Mar1 00:25:58.363: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po1
//端口1和2加入到以太通道Po1
A(config-if-range)#
*Mar1 00:26:00.091: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-chann
el1, changed state to up//在以太通道1上的线路协议,修改参数启用
A(config-if-range)#exit
A(config)#exit
A#
*Mar1 00:26:09.175: %SYS-5-CONFIG_I: Configured from console by console
A#
A#show interface port 1//查看通道1
Port-channel1 is up, line protocol is up//以太通道1开启,线路协议开启
Hardware is EtherChannel, address is cc00.0d08.f001 (bia cc00.0d08.f001)
//硬件是EtherChannel.地址是cc00.0d08.f001
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
//MTU: Maximum Transmission Unit (最大数据包传输单位) 1500字节
//BW: Band Width (频带宽度) 200000千位(表示通道建立成功,原值位100000Kbit)
//DLY: Delay (端口延迟) 1000毫秒
reliability 255/255, txload 1/255, rxload 1/255
//可靠性255/255,发送负载1/255,接收负载1/255
Encapsulation ARPA, loopback not set//封装ARPA接口回环没有设置
Keepalive set (10 sec)//保活设置(10秒)
Full-duplex, 100Mb/s//全双工,100Mb/s
Members in this channel: Fa0/1 Fa0/2//在此通道中的成员:端口0/1端口0/2
ARP type: ARPA, ARP Timeout 04:00:00//地址解析协议类型:ARPA,ARP超时04:00:00
Last input 00:00:00, output never, output hang never
//Last input:自从接口接受到最近的一个数据包后的时间。当该数据包是被precess-switch的方式转发的时候计数器会更新,而当该包是被fast-switch的方式转发时则不更新计数器00:00:00
//output:自从接口发送最后一个数据包以后
//output hang:接口因数据包传输时间过长而重启的时间,never为没有重启过
Last clearing of "show interface" counters never//清除接口统计计数器后的时间
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
//输入列队: 0/75/0/0 (长度/最大/丢弃/淹没);总输出丢弃:0
Queueing strategy: fifo//列队策略:fifo
Output queue: 0/40 (size/max)//输入列队:0/40 (长度/最大)
5 minute input rate 0 bits/sec, 0 packets/sec//5分钟输入率0位/秒,0包/秒
5 minute output rate 0 bits/sec, 0 packets/sec//5分钟输出率0位/秒,0包/秒
0 packets input, 0 bytes, 0 no buffer
//0包输入,0字节,由于没有足够缓冲丢弃的数据包0个
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
//收到的广播和多播数据包数量0,小于介质最小包大小而被丢弃的包的个数0,大于介质最大包大小而被丢弃的包的个数0,接口disable的次数
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
//输入错误0,CRC:接口接收到的冗余校验和的数量0,frame:接受到的含有CRC错误和非整数的十进制数目的数据包的数量0,overrun:因为输入的速率超出了接受者硬件的处理能力没有硬件缓存来处理的次数0,ignored:因为接口的内部缓存而造成的接受到数据包被忽略的数目
0 input packets with dribble condition detected//frame超长输入的数据包个数0
0 packets output, 0 bytes, 0 underruns
//系统发出的数据包格数0,系统接发的所有数据包0字节,发送者传输过快导致路由器无法处理的次数
0 output errors, 0 collisions, 1 interface resets
//接口认为的所有传输数据包的错误的总和0,因为以太网冲突导致重传的数据包的个数0,接口重启次数1
0 babbles, 0 late collision, 0 deferred
//传输的计时器到0,
//late collision:传输数据包序文报头后发生的碰撞叫late collisions。通常发生late collision都是因为以太网的线缆过长,超出了它所能传输的距离限制造成的
//deferred:因为载波的问题,芯片延后传输帧
0 lost carrier, 0 no carrier//传输过程中丢失载波次数,没有载波的次数
0 output buffer failures, 0 output buffers swapped out
//输出缓存错误0,输出缓存交换0
交换机B配置如下:
B#conf t
Enter configuration commands, one per line.End with CNTL/Z.
B(config)#interface range f0/1 – 2//端口1-2
B(config-if-range)#channel-group 2 mode on//配置以太通道2模式开启
Creating a port-channel interface Port-channel2
B(config-if-range)#
*Mar1 00:26:19.815: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po2
*Mar1 00:26:20.763: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po2
B(config-if-range)#
*Mar1 00:26:22.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-chann
el2, changed state to up
B(config-if-range)#exit
B(config)#exit
B#
*Mar1 00:26:28.135: %SYS-5-CONFIG_I: Configured from console by console
B#
B#show interface port 2
Port-channel2 is up, line protocol is up
Hardware is EtherChannel, address is cc00.1444.f001 (bia cc00.1444.f001)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
//BW: Band Width (频带宽度) 200000千位(表示通道建立成功,原值位100000Kbit)
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
Members in this channel: Fa0/1 Fa0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Step 4:配置上行速链路
在交换机C与D上配置上行速链路
交换机C配置如下:
C#conf t
Enter configuration commands, one per line.End with CNTL/Z.
C(config)#spanning-tree uplinkfast//配置上行速链路
C(config)#
*Mar1 00:29:44.051: %SPANTREE_FAST-7-PORT_FWD_UPLINK: VLAN3 FastEthernet0/11 moved to Forwarding (UplinkFast).
//VLAN3端口0/11移动到转发(上行速链路)
C(config)#exit
C#
*Mar1 00:30:03.931: %SYS-5-CONFIG_I: Configured from console by console
C#show spa brief
VLAN1
Spanning tree enabled protocol ieee uplinkfast enabled
//生成树开启的协议ieee上行速链路开启
Root IDPriority8192
Addresscc00.0d08.0000
Cost3019
Port12 (FastEthernet0/11)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 BLK12 32768 cc00.1444.0000 128.12
FastEthernet0/11128.121283019 FWD08192 cc00.0d08.0000 128.12
VLAN2
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.0d08.0001
Cost3019
Port12 (FastEthernet0/11)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 BLK12 32768 cc00.1444.0001 128.12
FastEthernet0/11128.121283019 FWD08192 cc00.0d08.0001 128.12
VLAN3
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0002
Cost3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
Interface Designated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0002 128.12
FastEthernet0/11128.121283019 BLK12 32768 cc00.0d08.0002 128.12
VLAN4
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0003
Cost 3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0003 128.12
FastEthernet0/11128.121283019 BLK12 32768 cc00.0d08.0003 128.12
C#
C#conf t
Enter configuration commands, one per line.End with CNTL/Z.
C(config)#interface f0/11//端口11
C(config-if)#shutdown//关闭
C(config-if)#
*Mar1 00:32:48.647: %SPANTREE_FAST-7-PORT_FWD_UPLINK: VLAN1 FastEthernet0/10 moved to Forwarding (UplinkFast).
//VLAN1端口0/10移动到转发(上行速链路)
*Mar1 00:32:49.183: %DTP-5-NONTRUNKPORTON: Port Fa0/11 has become non-trunk
//端口0/11已经变成非中继
*Mar1 00:32:50.339: %LINK-5-CHANGED: Interface FastEthernet0/11, changed state
to administratively down
//端口0/11,修改参数关闭管理
*Mar1 00:32:51.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/11, changed state to down
//在0/11上线路协议,修改参数为关闭
C(config-if)#exit
C(config)#exit
C#
*Mar1 00:33:00.471: %SYS-5-CONFIG_I: Configured from console by console
C#show spa brief
VLAN1
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.0d08.0000
Cost3031
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD12 32768 cc00.1444.0000 128.12
//端口0/11被关闭后,自动启用被阻塞的端口0/10并变成转发状态,时间大约50秒
VLAN2
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.0d08.0001
Cost3031
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD12 32768 cc00.1444.0001 128.12
//端口0/11被关闭后,自动启用被阻塞的端口0/10并变成转发状态,时间大约50秒
VLAN3
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0002
Cost3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0002 128.12
VLAN4
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0003
Cost3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.1580.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts Cost Bridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0003 128.12
交换机D配置如下:
D#conf t
Enter configuration commands, one per line.End with CNTL/Z.
D(config)#spanning-tree uplinkfast//配置上行速链路
D(config)#
*Mar1 00:30:29.371: %SPANTREE_FAST-7-PORT_FWD_UPLINK: VLAN3 FastEthernet0/11 moved to Forwarding (UplinkFast).
D(config)#exit
D#
*Mar1 00:30:33.723: %SYS-5-CONFIG_I: Configured from console by console
D#show spa brief
VLAN1
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.0d08.0000
Cost3019
Port12 (FastEthernet0/11)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.165c.0000
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 BLK12 32768 cc00.1444.0000 128.11
FastEthernet0/11128.121283019 FWD08192 cc00.0d08.0000 128.11
VLAN2
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.0d08.0001
Cost3019
Port12 (FastEthernet0/11)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.165c.0001
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 BLK12 32768 cc00.1444.0001 128.11
FastEthernet0/11128.121283019 FWD08192 cc00.0d08.0001 128.11
-
VLAN3
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0002
Cost3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.165c.0002
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge IDPort ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0002 128.11
FastEthernet0/11128.121283019 BLK12 32768 cc00.0d08.0002 128.11
VLAN4
Spanning tree enabled protocol ieee uplinkfast enabled
Root IDPriority8192
Addresscc00.1444.0003
Cost3019
Port11 (FastEthernet0/10)
Hello Time2 secMax Age 20 secForward Delay 15 sec
Bridge IDPriority49152
Addresscc00.165c.0003
Hello Time2 secMax Age 20 secForward Delay 15 sec
Aging Time 300
InterfaceDesignated
NamePort ID Prio CostSts CostBridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/10128.111283019 FWD08192 cc00.1444.0003 128.11
FastEthernet0/11128.121283019 BLK12 32768 cc00.0d08.0003 128.11
Step 5:配置速端口
配置交换机C与D的1~5号端口为速端口
交换机C配置如下:
C#conf t
Enter configuration commands, one per line.End with CNTL/Z.
C(config)#interface range f0/1 – 5//端口0/1 - 5
C(config-if-range)#spanning-tree portfast//配置速端口
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
//%警告:速端口只能被用于连接到单主机、集线器、集中器、交换机、网桥等端口
//当启用速端口时,会操正临时生成树环路。小心使用!
%Portfast has been configured on FastEthernet0/1 but will only
have effect when the interface is in a non-trunking mode.
//%速端口已经在端口0/1上启用,但是它只作用在非中继模式的端口上
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/2 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/3 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/4 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/5 but will only
have effect when the interface is in a non-trunking mode.
C(config-if-range)#exit
C(config)#exit
交换机D配置如下:
D#conf t
Enter configuration commands, one per line.End with CNTL/Z.
D(config)#interface range f0/1 – 5//端口0/1 - 5
D(config-if-range)#spanning-tree portfast//配置速端口
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/1 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/2 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/3 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/4 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/5 but will only
have effect when the interface is in a non-trunking mode.
D(config-if-range)#exit
D(config)#exit
3.实验总结
STP协议在逻辑上断开网络的环路,防止广播风暴的产生,而一旦正在用的线路出现故
被逻辑上断开的线路又被连接,重新传输数据。此实验的配置要点有:
l配置交换机的根网桥方法有两种:直接配置网桥为根网桥,即vlan .No root primary;配置网桥优先级为8129。
l配置以太通道的原则有:参与捆绑的端口必须属于同一VLAN;如果端口配置的中继模式,那么,应该在链路的两端将通道中的所有端口配置成相同的中继模式。
l参与捆绑的端口的物理参数设置必须相同,应该有同样的速度和全/半双工模式设置。