匈牙利扩展 - Air Raid POJ - 1422

                                                Air Raid
                                            Time Limit: 1000MS      
                                            Memory Limit: 10000K

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

题目大意:一个镇里所有的路都是单向路且不会组成回路。
派一些伞兵去那个镇里,要到达所有的路口,有一些或者没有伞兵可以不去那些路口,只要其他人能完成这个任务。每个在一个路口着陆了的伞兵可以沿着街去到其他路口。我们的任务是求出去执行任务的伞兵最少可以是多少个。

思路:
这个题就是个最小路径覆盖问题。
路径覆盖的定义是:在有向图中找一些路径,使之覆盖了图中的所有顶点,就是任意一个顶点都跟那些路径中的某一条相关联,且任何一个顶点有且只有一条路径与之关联,一个单独的顶点是一条路径.最小路径覆盖就是最少的路径覆盖数。
有定理: 最小路径覆盖 = 图的顶点数 – 最大匹配数。

总结:
1.用匈牙利算法求二分匹配,利用最小路径覆盖=顶点总数-最大匹配
2.把每个点拆点为出点和入点

题目链接:Air Raid POJ - 1422

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#define ll long long
using namespace std;

const int MAXN = 1e5+7;

vector<int>g[MAXN];
int from[MAXN];
bool use[MAXN];

bool match(int x)
{
    for(int i = 0;i < g[x].size(); i++)
    {
        if(!use[g[x][i]])
        {
            use[g[x][i]] = true;
            if(from[g[x][i]] == -1||match(from[g[x][i]]))
            {
                from[g[x][i]] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(int s)
{
    int tot = 0;
    memset(from, 255, sizeof(from));
    for(int i = 1; i <= s; i++)
    {
        memset(use, 0, sizeof(use));
        if(match(i)) tot++;
    }
    return tot;
}


int main()
{
    int t,p,n,c,stu,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&n);
        for(int i = 1; i <= n; i++)
        {
                scanf("%d%d",&a,&b);
                g[a].push_back(b);
        }
        int ss = hungary(p);
        printf("%d\n",(p - ss));
        for(int i = 1;i <= p; i++)
            g[i].clear();
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值