HDU 1002 题解

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 410313    Accepted Submission(s): 79511


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
21 2112233445566778899 998877665544332211
 
Sample Output
 
 
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110

处理大数问题一般用java会很简单

这题需要注意的是输出格式,在输出最后一个测试数据结果时,不再输出空白行!!

AC代码(java):

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int t=sc.nextInt();
		for(int i=1;i<=t;i++)
		{
			BigInteger a=sc.nextBigInteger();
			BigInteger b=sc.nextBigInteger();
			System.out.println("Case "+i+":");
			if(i<t)
			{
				System.out.println(a+" + "+b+" = "+a.add(b));
				System.out.println();
			}
			else
				System.out.println(a+" + "+b+" = "+a.add(b));
		}
	}
}

同时,ACM中提交Java代码的规范格式:

多行输入时的代码格式:

Scanner sc= new Scanner(System.in);  
while(sc.hasNext()){  
            ......  
        } 

类名:

public class Main {
} 
题目链接: HDU 1002




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值