HDU 1002 A + B Problem II C++解法

题目

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码

由于A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
所以必须用字符串实现大数加法

大数加法

  1. 判断是否为特殊情况

    1.1a,b字符串皆为空,则输出0
    1.2a字符串为空,则输出b
    1.3b字符串为空,则输出a

  2. 翻转a,b字符串

    因为大数加法是从低位往高位加,而字符串是从高位往低位写入的,所以需要对a,b字符串进行翻转,这里运用的是reverse函数

    头文件要加algorithm
    reverse(N.begin(), N.end())

  3. 总是让a作为较短的那个字符串,而b作为目标字符串(每一位的加法只需要循环到lena即可)

    这里写了两个swap函数来交换字符串和表示字符串长度的变量

void swapstring(string &a, string &b)
{
	string t = a;
	a = b;
	b = t;
	return;
}
void swap(int &a, int &b){
	int t = a;
	a = b;
	b = t;
	return;
}
  1. 设置进位标志flag

  2. a,b都有数的每一位的加法计算
    5.1用isdigit判断加后的和数是否仍为0~9的数字
    5.2若当前进位符为true则+1且flag = false,回溯为不进位
    5.3若不为数字,则flag = true进位,并且b[i] -= 10

  3. a被用完了若还有进位则靠这一位进位还要与剩余的b字符串的高位数进行加法运算
    循环直到进位符为false,表示不再进位了

    6.1如果长度相等,b字符串最高位添一位1,flag = false
    6.2否则在走到的当前位上+1
    ~6.2.1加后如果不是数字,进位符flag = true,且b[lena] -= 10
    ~6.2.2如果是数字,flag = false

  4. 翻转目标字符串b,返回b

string SUM(string a, string b){
	if (a == ""&&b == "")
		return "0";
	if (a == "")
		return b;
	if (b == "")
		return a;
	/*特殊情况*/

	int lena = a.length(),lenb=b.length();
	reverse(a.begin(), a.end());
	reverse(b.begin(), b.end());
	bool flag = false;
	if (lena > lenb){
		swap(lena, lenb);
		swapstring(a, b);
	}
	for (int i = 0; i < lena; i++){
		b[i] += a[i] - '0';
		if (flag){
			b[i] += 1;
			flag = false;
		}
		if (!isdigit(b[i])){
			flag = true;
			b[i] -= 10;
		}
	}
	while(flag){//较短的最高位进位不知道要进几次位
		if (lena == lenb){
			b += '1';
			flag = false;
		}
		else{
			b[lena] += 1;
			if (!isdigit(b[lena])){
				flag = true;
				b[lena] -= 10;
			}
			else
				flag = false;
		}	
		lena++;
	}
	reverse(b.begin(), b.end());
	return b;
}

AC代码

#include<stdio.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<stdlib.h>
using namespace std;
void swapstring(string &a, string &b)
{
	string t = a;
	a = b;
	b = t;
	return;
}
void swap(int &a, int &b){
	int t = a;
	a = b;
	b = t;
	return;
}
string SUM(string a, string b){
	if (a == ""&&b == "")
		return "0";
	if (a == "")
		return b;
	if (b == "")
		return a;
	/*特殊情况*/

	int lena = a.length(),lenb=b.length();
	reverse(a.begin(), a.end());
	reverse(b.begin(), b.end());
	bool flag = false;
	if (lena > lenb){
		swap(lena, lenb);
		swapstring(a, b);
	}
	for (int i = 0; i < lena; i++){
		b[i] += a[i] - '0';
		if (flag){
			b[i] += 1;
			flag = false;
		}
		if (!isdigit(b[i])){
			flag = true;
			b[i] -= 10;
		}
	}
	while(flag){//较短的最高位进位不知道要进几次位
		if (lena == lenb){
			b += '1';
			flag = false;
		}
		else{
			b[lena] += 1;
			if (!isdigit(b[lena])){
				flag = true;
				b[lena] -= 10;
			}
			else
				flag = false;
		}	
		lena++;
	}
	reverse(b.begin(), b.end());
	return b;
}
int main()
{
	int t;
	scanf("%d", &t);
	for(int i=1;i<=t;i++)
	{
		string a, b;
		cin >> a >> b;
		cout << "Case " << i << ":" << endl;
		cout << a << " + " << b << " = " << SUM(a, b) << endl;
		if (i != t)
			cout << endl;
	}
	system("pause");
	return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Deosiree

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值