vue 加载数据 影响seu_Hackerrank,join与split空格妙用

Problem Statement

You are given a string S. Your task is to capitalize each word of S.

Input Format

A single line of input containing the string, S.

Constraints

0

The string consists of alphanumeric characters and spaces.

Output Format

Print the capitalized string, S.

Sample Input

hello world

Sample Output

Hello World

1、首先我尝试写程序,我的代码如下:

[print(str.capitalize(s), end=' ') for s in input().split()]

结果运行错误,因为我忽略了多个空格的影响

2、用正则表达式解决,

import re

print re.sub(r'\w+', lambda x : x.group(0).capitalize(), raw_input())

运行成功

3、官方提供的答案,真是令人意外啊!!!

print ' '.join(word.capitalize() for word in raw_input().split(' '))

通过这种方式能解决多个空格的问题,我不能明白为何能这么作,只能猜测join函数能记住split函数分出的空格。

经测试,这样也是可以的,如下:

a=[word.capitalize() for word in raw_input().split(' ')]

print ' '.join(a)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值