1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9

思路

  1. 将所有的数存放在数组中,由于每次只能和0交换,假设a[1]=0,而a[t]=1,那么交换a[1]与a[t],如果按照a[i]=num的格式,我们找a[t]=num的时候,需要遍历整个数组,于是采用a[num]=i,这样就方便找到位置了。
  2. 使用count记录a[i]!=i的个数(不包含0),不包含0是因为只要其他n-1个数的位置固定好了,0的就也ok了。如果是n的话,最后0与另一个互换位置是count是要-2的。循环条件为count>0,存在不在本位的数字。
  3. 只要存在不在本位的数字:如果a[0]!=0,就一直交换;如果a[0]=0,说明0到了0的位置,可是还有没在对应位置的数,于是找到离a[0]最近的那个位置的数,交换即可

代码

#include<cstdio>
#include<algorithm>
using namespace std; 
const int maxn=100005;
int main(){
	int n,a[maxn],count=0,num;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&num);
		a[num]=i;
		if(a[num]!=num && num!=0){
			count++;
		}
	}
	int k=1,ans=0;
	while(count>0){
		if(a[0]==0){
			while(k<n){
				if(a[k]!=k){//找到第一个不在本位上的数字了 
					swap(a[0],a[k]);
					ans++;
					break;
				}
				k++;
			}	
		}
		while(a[0]!=0){
			swap(a[0],a[a[0]]);
			count--;
			ans++;
		}
	}
	
	printf("%d\n",ans);
	return 0; 
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值