HDU 1003 MAX SUM(DP,最大连续子序列和+路径存储)

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

经典的最大连续子序列和问题,状态转移方程dp[i] = max(dp[i - 1] + a[i], a[i])
本题的区别就是要把最优子序列的起点和终点也要输出,因为dp[i]表示的意思是,以a[i]结尾的最大连续子序列的和。所以终点肯定是其自己,那么我们只需要用一个s数组来存储起点就可以了,在更新dp值的时候顺便更新一下s数组的值即可。
代码如下:

#include<iostream>
using namespace std;

const int MIN = -1500;
const int maxn = 100005;
int n;
int e = 0; 
int s[maxn];
int dp[maxn];
int a[maxn];

void Clear()
{
	for(int i = 1;i <= n;i++)
	{
		dp[i] = 0;
		s[i] = 0;
		a[i] = 0;
	}
}

int Dp()
{
	dp[1] = a[1];
	s[1] = 1;
	//填充dp数组 
	for(int i = 2;i <= n;i++)
	{
		if(dp[i - 1] + a[i] >= a[i])
		{
			dp[i] = dp[i - 1] + a[i];
			s[i] = s[i - 1];
		}
		else
		{
			dp[i] = a[i];
			s[i] = i;
		}
	}
	//再找dp数组中的最大值
	int max_res = MIN;
	for(int i = 1;i <= n;i++)
	{
		if(dp[i] > max_res)
		{
			max_res = dp[i];
			e = i;	
		}
	} 
	return max_res;
}

int main()
{
	int t, i = 1;
	cin >> t;
	while(i <= t)
	{
		cin >> n;
		Clear();
		for(int j = 1;j <= n;j++)
		{
			cin >> a[j];
		}
		cout << "Case " << i << ":" << endl;
		cout << Dp();
		cout << " " << s[e] << " " << e << endl;
		if(i != t)
			cout << endl;
		i++;
	}
	return 0;
}

O(n)时间复杂度就可以搞定!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值