树2 List Leaves

树2 List Leaves
Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

4 1 5

#include <stdio.h>
#include <stdlib.h>
#define N 10
typedef struct Node{
    int data;
    int left;
    int right;
}NODE;

int CreatTree(NODE BT[]);
void LevelorderTraversal(int root, NODE BT[]);

int main()
{
    int root;
    NODE BT[N];

    root = CreatTree(BT);
    LevelorderTraversal(root, BT);
    return 0;
}

/*用一个结构数组接收每个结点,每个元素是一个结构体代表一个树节点,包括自身的信息、左儿子的下标、
  右儿子的下标并返回根节点的下标
*/
int CreatTree(NODE BT[])
{
    int n, i, root = -1;
    char l, r;
    int check[N];//用来标记该位置的结点不是根结点

    for(i = 0; i < N; i++) check[i] = 0;
    QQ: ;
    scanf("%d", &n);
    if(n < 0 || n > 10){
        printf("n输入不合法!\n请重新输入\n");
        goto QQ;
    }
    if(n){
        for(i = 0; i < n; i++){
            BT[i].data = i;
            scanf(" %c %c", &l, &r);
            if(l != '-'){
                BT[i].left = l-'0';
                check[l - '0'] = 1;//标记该结点的左儿子不是根节点
            }else{
                BT[i].left = -1;
            }
            if(r != '-'){
                BT[i].right = r - '0';
                check[r - '0'] = 1;//标记该结点的右儿子不是根节点
            }else{
                BT[i].right = -1;
            }
        }
        for(i = 0; i < n; i++){//寻找根节点的下标
            if(!check[i]) break;
        }
        root = i;
    }
    return root;
}

/*以层序遍历的方式即队列的方式来寻找叶节点*/
void LevelorderTraversal(int root, NODE BT[])
{
    int queue[N];
    int front, rear, node;
    int flag = 0;

    //层序遍历就是借助队列来实现一个结点的出队后左右儿子队尾入队,直到队列为空
    front = 0; rear = 0; queue[rear++] = root;
    while(rear > front){
        node = queue[front++];
        if(BT[node].left == -1 && BT[node].right == -1){
            if(!flag){
                printf("%d", BT[node].data);
                flag = 1;
            }else{
                printf(" %d", BT[node].data);
            }
        }
        if(BT[node].left != -1){
            queue[rear++] = BT[node].left;
        }
        if(BT[node].right != -1){
            queue[rear++] = BT[node].right;
        }
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值