1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:
Each input file contains one test case, which gives the integer N (1<N<​231次方).
Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:
630

Sample Output:
3
567

要学会动态地去更新一些所求数值

#include<stdio.h>
#include<math.h>
typedef long long ll;

int main() {
	ll n;
	scanf("%lld", &n);
	ll sqr = (int)sqrt(1.0 * n), ansI = 0, anslen = 0;
	for(ll i = 2; i <= sqr; ++i) {
	//从2开始遍历到根号n,看n能被多少个连续整数整除
	//ansI保存连续整数的第一个,anslen保存最大的连续长度 
		ll temp = 1, j = i;
		while(1) {
			temp *= j;
			//更新temp之后立即进行判断是否temp能整除n
			//如果不立即判断,ansI与anslen会更新不该更新的内容 
			if(n % temp != 0) {
				break;
			}
			if(j - i + 1 > anslen) {
				ansI = i;
				anslen = j - i + 1;
			}
			++j; 
		}
	}
	
	if(anslen == 0) { //最大长度为0,说明本身是个指数,因此输出其本身 
		printf("1\n%lld", n);
	} else {
		printf("%lld\n", anslen);
		for(int i = 0; i < anslen; ++i) { //输出连续整数 
			printf("%lld", ansI + i);   
			if(i < anslen - 1) {
				printf("*");
			}
		}
	}
	
	return 0;
} 






//这道题不是找质因子,方向错了 
/*const int maxn = 100005;
int prime[maxn], pNum = 0;
bool p[maxn] = {0};

void Findprime(int k) {
	for(int i = 2; i <= k; ++i) {
		if(p[i] == false) {
			prime[pNum++] = i;
			for(int j = i + i; j <= k; j += i) {
				p[j] = true;
			}
		}
	}
} 

struct factor {
	int x;  //质因子 
	int cnt; //该质因子个数 
} fac[10];

int main() {
	int n;
	scanf("%d", &n);
	int num = 0; //用于计数质因子个数
	int count = 0;  //用于计算连续质因子个数
	Findprime(n);
	int sqr = (int)sqrt(1.0 * n);
	for(int i = 0; i < pNum && prime[i] <= sqr; ++i) {
		if()
	} 
}*/```

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值