1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

最大容量的设置就像数据机构里面给出一个出栈顺序,问你最多需要多少空间,这里的是合法顺序所需的最大容量。
这道题就是去模拟出栈,一次入栈,如果当前元素是出栈顺序中的元素,则出栈,如果出栈顺利,则序列合法。

#include <stdio.h>
#include <stack>
using namespace std;

const int maxn = 1005;
int a[1005];  //用于接收给出的序列
stack<int> st;  //用于模拟给出的出栈序列

int main() {
	int m, n, T;
	scanf("%d %d %d", &m, &n, &T); //栈最大容量,出栈序列长度,查询次数
	while(T--) {
		while(!st.empty()) {
			st.pop();  //清空栈以初始化 
		}
		for(int i = 1; i <= n; ++i) {
			scanf("%d", &a[i]);  //接收序列的具体数据 
		}
		int current = 1;
		//设置栈的最大容量是因为,在合理的出栈顺序中最多需要的栈空间
		//若中途栈容量超过了最大栈容量,说明出栈顺序并不合法 
		bool flag = true;
		//模拟给出的出栈顺序,先按照1~n入栈,如果当前入栈的元素等于提给序列的元素
		//则将其出栈,若中途栈容量大于题设最大容量,直接跳出循环,输出NO
		//若按照所给的序列顺利出栈结束,则说明该出栈顺序合法 
		for(int i = 1; i <= n; ++i) {
			st.push(i);  //入栈
			if(st.size() > m) {  //序列不合法 
				flag = false;
				break;
			} 
			while(!st.empty() && st.top() == a[current]) {
				st.pop();
				current++;
			}
		}
		if(st.empty() == true && flag) {
			printf("YES\n");
		} else {
			printf("NO\n");
		}
	} 
	
	return 0;
}```

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值