1071 Speech Patterns (25分)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.
Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
Sample Input:
Can1: “Can a can can a can? It can!”

Sample Output:
can 5

和前一题很像。

#include<iostream>
#include<string>
#include<map>
using namespace std;

bool check(char c) { //判断所给字符是否为有效字符 
	if(c >= 'A' && c <= 'Z') {
		return true;
	}
	if(c >= 'a' && c <= 'z') {
		return true;
	}
	if(c >= '0' && c <= '9') {
		return true;
	}
	
	return false;
} 

int main() {
	string str;
	getline(cin, str);  //输入整行字符串,包括空格
	map<string, int> count;
	int i = 0;
	while(i < str.length()) {
		string word;
		while(check(str[i]) == true && i < str.size()) {
			if(str[i] >= 'A' && str[i] <= 'Z') {
				str[i] += 32;     //将小写字母转化为大写字母 
			}
			word += str[i]; //将有效字符组成一个单词
			++i;
		}
		if(word != "") { //如果单词非空 
			if(count.find(word) != count.end()) { //map找不到返回最后一个元素的下一个位置 
				count[word]++;
			} else {
				count[word] = 1;
			}
		}
    	while(check(str[i]) == false && i < str.size()) {  //跳过无效字符 
		    ++i; 
		} 

	}
	
	//没能跳过无效字符 
	/*for(int i = 0; i < str.length(); ++i) {
		string word;
		if(check(str[i])) {
			if(str[i] >= 'A' && str[i] <= 'Z') {
				str[i] += 32;     //将小写字母转化为大写字母 
			}
			word += str[i]; //将有效字符组成一个单词 
		} else {
			if(count.find(word) != count.end()) {
				count[word]++;
			} else {
				count[word] = 1;
			}
		}
	} */
	
	string ans;
	int max = 0;
	for(map<string, int>::iterator it = count.begin(); it != count.end(); ++it) {
		if(it -> second > max) {
			ans = it -> first;  //保存出现最多的单词的字符串,键值
			max = it -> second; 
		}
	} 
	
	cout << ans << " " << max;
	
	return 0;
}```

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值