两个有序序列的中位数(25 分)

两个有序序列的中位数(25 分)

已知有两个等长的非降序序列S1, S2, 设计函数求S1与S2并集的中位数。有序序列A0,A​1,⋯,A​N−1的中位指A
​(N−1)/2的值,即第⌊(N+1)/2⌋个数(A0为第1个数)。

输入格式:

输入分三行。第一行给出序列的公共长度N(0<N≤100000),随后每行输入一个序列的信息,即N个非降序排列的整数。数字用空格间隔。

输出格式:

在一行中输出两个输入序列的并集序列的中位数。

输入样例1:

5
1 3 5 7 9
2 3 4 5 6
输出样例1:

4
输入样例2:

6
-100 -10 1 1 1 1
-50 0 2 3 4 5
输出样例2:

1

思路

第一段代码使用stl的set_union方法求并集,用resize去除多余的空元素。
但并不能AC,我暂时还没法解决……
测试点 提示 结果 耗时 内存
0 样例1等价,奇数长度 答案正确 2 ms 300KB
1 样例2等价,偶数长度 答案正确 2 ms 256KB
2 两序列尾首衔接 答案正确 3 ms 256KB
3 两序列首尾衔接 答案正确 2 ms 304KB
4 最小N 答案正确 2 ms 256KB
5 最大N 答案错误 45 ms 1872KB
第二段代码用数组模拟了链表,很巧妙。哈哈也是CSDN上看来的,原谅我没有记录出处。

源码1

/*
	Name:7-4 两个有序序列的中位数(25 分)
	Author: shou1651312
	Date:2017年9月18日 01:28:11
	Description:数据结构实验1-2

*/
#include<iostream>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<numeric>
using namespace::std;
int main()		//version1 STL 21/25
{
	int N;
	scanf("%d",&N);
	vector<int> V1(N);
	vector<int> V2(N);
	for(int i=0;i<N;i++)
		scanf("%d",&V1[i]);
	for(int i=0;i<N;i++)
		scanf("%d",&V2[i]);
	vector<int> V3(2*N);
	auto it=set_union(V1.begin(),V1.end(),V2.begin(),V2.end(),V3.begin());
	int n=it-V3.begin();
		V3.resize(n);//由此学习了容器的resize的使用
	int index;
	if(n%2==0)
		index=n/2-1;
	else
		index=(n+1)/2-1;
	printf("%d",V3[index]);
	return 0;
}

源码2

#include<iostream>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<numeric>
using namespace::std;
int a[100005], b[100005];	//version2 chainlist  25/25
int DealWith(int n)
{
	int ai = 0, bi = 0;
	int i, j;
	int m = (2*n+1)/2;
	while(ai + bi < m - 1)
	{
		if(a[ai] >= b[bi])
			bi++;
		else
			ai++;
	}
	return a[ai]>b[bi]?b[bi]:a[ai];
}
int main()
{
	int n;
	scanf("%d",&n);
	int i;
	for(i = 0; i < n; ++i)
		scanf("%d", &a[i]);
	for(i = 0; i < n; ++i)
		scanf("%d", &b[i]);
	printf("%d\n", DealWith(n));    
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值