POJ 2377(Bad Cowtractors )最小生成树

Bad Cowtractors
Time Limit: 1000MS

Memory Limit: 65536K
Total Submissions: 18598

Accepted: 7527
Description
Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.
Input
* Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
    Output
  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
    Sample Input
    5 8
    1 2 3
    1 3 7
    2 3 10
    2 4 4
    2 5 8
    3 4 6
    3 5 2
    4 5 17
    Sample Output
    42
    Hint
    OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
最小生成树有两种生成方式,一种是prime算法一种是kruskal算法,这里重点讲述一下kruskal算法,
预备知识:并查集,sort排序,
并查集是表示关系的一种结构,实现简单,sort排序是封装好的排序方式。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stack>
#include<algorithm>
#define MAXN 10005

using namespace std;
const int inf = 0x3f3f3f3f;
struct sep{
    int u;
    int v;
    int dis;
}node[20005];
int n,m;
bool cmp(sep a,sep b){
    return a.dis>b.dis;
}//用于sort排序
int father[MAXN];//并查集数组
int mfind(int x){
    if(x!=father[x]){
        father[x] = mfind(father[x]);
    }
    return father[x];
}
void init(){
    for(int i=0;i<=n;i++){
        father[i] = i;
    }
}
int mix(int a,int b){
    int na = mfind(a);
    int nb = mfind(b);
    if(na!=nb){
        father[na] = nb;
        return 1;
    }
    return 0;
}
long long kruskal(){
    long long sum=0;
    init();
    sort(node,node+m,cmp);
    int ez = 0;//ez表示边的 数目,最小生成树也是树,满足树的性质点的数目比边的数目多1
    for(int i=0;i<m&&ez<n-1;i++){
        if(mix(node[i].u,node[i].v))
        {
            sum+=node[i].dis;
            ez++;
        }

    }
    if(ez==n-1)
        return sum;
    else
        return -1;
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&node[i].u,&node[i].v,&node[i].dis);
        }
        printf("%d\n",kruskal());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值